diff mbox series

[bug#69109] gnu: tmux: Update to 3.4.

Message ID 20240213221101.624345-1-ashish.is@lostca.se
State New
Headers show
Series [bug#69109] gnu: tmux: Update to 3.4. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Feb. 13, 2024, 10:10 p.m. UTC
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/tmux.scm (tmux): Update to 3.4.

Signed-off-by: Ashish SHUKLA <ashish.is@lostca.se>
---
 gnu/packages/tmux.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

Skyler Ferris Feb. 14, 2024, 2:10 a.m. UTC | #1
Hi Ashish,

I'm adding some review notes to this issue. To avoid any confusion, I 
want to be clear that I am not a committer, but I hope that these notes 
will help a committer process this patch more quickly.

There is no cryptographic signature hosted on GitHub. My computer 
downloaded a file from the specified location with the same hash as 
specified in the patch.

I applied the patch to commit ac470c516e19f194228edf9e348bdbc7fc10f97a 
and it applied cleanly.

I built the new version of tmux for an x86_64 machine and successfully 
ran it from the store (my machine is technically a Xen guest, running on 
x86_64 hardware).

I also built it with `--rounds=2` and no differences were reported.

The output of `guix refresh --list-dependent tmux` indicated that there 
are 2 dependency leaves: `zsh-autosuggestions` and `python-daemux`. The 
former built successfully. The latter triggered a build of 
`python-libtmux` which built successfully. The build of `python-daemux` 
failed, but this seems unrelated. I am seeing the same error that is 
shown in the most recent x86_64 build: 
http://ci.guix.gnu.org/build/2678780/log

Regards,
Skyler
Ashish Feb. 14, 2024, 11:16 a.m. UTC | #2
Hi Skyler,

Thanks for taking time to review the patch.

On Wed, Feb 14, 2024 at 02:10:53AM +0000, Skyler Ferris wrote:
> Hi Ashish,
> 
> I'm adding some review notes to this issue. To avoid any confusion, I 
> want to be clear that I am not a committer, but I hope that these notes 
> will help a committer process this patch more quickly.
> 
> There is no cryptographic signature hosted on GitHub. My computer 
> downloaded a file from the specified location with the same hash as 
> specified in the patch.

I assumed GitHub doesn't tamper the archives, and since the archive was downloaded over HTTPS, the possibility of MITM tampering it is almost zero. I'll ofcourse keep in mind to use the upstream hashes/signatures when provided.

> I applied the patch to commit ac470c516e19f194228edf9e348bdbc7fc10f97a 
> and it applied cleanly.
> 
> I built the new version of tmux for an x86_64 machine and successfully 
> ran it from the store (my machine is technically a Xen guest, running on 
> x86_64 hardware).
> 
> I also built it with `--rounds=2` and no differences were reported.
> 
> The output of `guix refresh --list-dependent tmux` indicated that there 
> are 2 dependency leaves: `zsh-autosuggestions` and `python-daemux`. The 
> former built successfully. The latter triggered a build of 
> `python-libtmux` which built successfully. The build of `python-daemux` 
> failed, but this seems unrelated. I am seeing the same error that is 
> shown in the most recent x86_64 build: 
> http://ci.guix.gnu.org/build/2678780/log

Indeed, it looks the same to me.
diff mbox series

Patch

diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 4d9dea2396..96d95da0cb 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -36,6 +36,7 @@  (define-module (gnu packages tmux)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages check)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages libevent)
@@ -45,7 +46,7 @@  (define-module (gnu packages tmux)
 (define-public tmux
   (package
     (name "tmux")
-    (version "3.3a")
+    (version "3.4")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -53,10 +54,12 @@  (define-public tmux
                     version "/tmux-" version ".tar.gz"))
              (sha256
               (base32
-               "0gzrrm6imhcp3sr5vw8g71x9n40bbdidwvcdyk2741xx8dw39zg4"))))
+               "1ahr7si3akr55hadyms3p36f1pbwavpkbfxpsq55ql5zl3gbh6jm"))))
     (build-system gnu-build-system)
     (inputs
      (list libevent ncurses))
+    (native-inputs
+     (list bison))
     (home-page "https://github.com/tmux/tmux/wiki")
     (synopsis "Terminal multiplexer")
     (description