diff mbox series

[bug#67512,v2,1/4] gnu: Move icu4c-73 from gnuzilla to icu4c.

Message ID 20240211192031.32284-2-ian@retrospec.tv
State New
Headers show
Series [bug#67512,v2,1/4] gnu: Move icu4c-73 from gnuzilla to icu4c. | expand

Commit Message

Ian Eure Feb. 11, 2024, 7:20 p.m. UTC
* gnu/packages/icu4c.scm (icu4c-73): New variable.
* gnu/packages/gnuzilla.scm (icu4c-73-promise): Delete variable.

Change-Id: I017e1416b70ecb94313aeb71aa4a0cafdfe0e9ab
---
 gnu/packages/gnuzilla.scm | 27 +--------------------------
 gnu/packages/icu4c.scm    | 22 ++++++++++++++++++++++
 2 files changed, 23 insertions(+), 26 deletions(-)

Comments

Mark H Weaver Feb. 11, 2024, 9:40 p.m. UTC | #1
Ian Eure <ian@retrospec.tv> writes:

> * gnu/packages/icu4c.scm (icu4c-73): New variable.
> * gnu/packages/gnuzilla.scm (icu4c-73-promise): Delete variable.

Looks good to me.

     Thanks,
       Mark
Clément Lassieur Feb. 11, 2024, 10:14 p.m. UTC | #2
On Sun, Feb 11 2024, Ian Eure wrote:

> * gnu/packages/icu4c.scm (icu4c-73): New variable.
> * gnu/packages/gnuzilla.scm (icu4c-73-promise): Delete variable.
>
> Change-Id: I017e1416b70ecb94313aeb71aa4a0cafdfe0e9ab

I'm sorry, but with this patch neither mullvadbrowser or torbrowser
builds.

I get:

--8<---------------cut here---------------start------------->8---
error: icu4c-73-promise: unbound variable
--8<---------------cut here---------------end--------------->8---

Clément
Ian Eure Feb. 11, 2024, 11:23 p.m. UTC | #3
Clément Lassieur <clement@lassieur.org> writes:

> On Sun, Feb 11 2024, Ian Eure wrote:
>
>> * gnu/packages/icu4c.scm (icu4c-73): New variable.
>> * gnu/packages/gnuzilla.scm (icu4c-73-promise): Delete 
>> variable.
>>
>> Change-Id: I017e1416b70ecb94313aeb71aa4a0cafdfe0e9ab
>
> I'm sorry, but with this patch neither mullvadbrowser or 
> torbrowser
> builds.
>
> I get:
>
> error: icu4c-73-promise: unbound variable
>

It’s a oneliner fix, I’ll have an updated patch momentarily.

The root of the issue is that `make-torbrowser' is very naughty 
and uses the unexported icu4c-73-promise symbol from (gnu packages 
gnuzilla), so it broke when I moved it to the proper (gnu packages 
icu4c) module.

  — Ian
Clément Lassieur Feb. 11, 2024, 11:34 p.m. UTC | #4
On Sun, Feb 11 2024, Ian Eure wrote:

> Clément Lassieur <clement@lassieur.org> writes:
>
>> On Sun, Feb 11 2024, Ian Eure wrote:
>>
>>> * gnu/packages/icu4c.scm (icu4c-73): New variable.
>>> * gnu/packages/gnuzilla.scm (icu4c-73-promise): Delete variable.
>>>
>>> Change-Id: I017e1416b70ecb94313aeb71aa4a0cafdfe0e9ab
>>
>> I'm sorry, but with this patch neither mullvadbrowser or torbrowser
>> builds.
>>
>> I get:
>>
>> error: icu4c-73-promise: unbound variable
>>
>
> It’s a oneliner fix, I’ll have an updated patch momentarily.
>
> The root of the issue is that `make-torbrowser' is very naughty and uses the
> unexported icu4c-73-promise symbol from (gnu packages gnuzilla), so it broke
> when I moved it to the proper (gnu packages icu4c) module.

Well thanks for making it less naughty then ;)
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 5f77512427..094ff348e9 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -375,31 +375,6 @@  (define-public mozjs-78
      (list icu4c-69 readline zlib))))
 
 
-;;
-;; Needed for IceCat 115.
-;;
-(define icu4c-73-promise
-  (delay
-    (package
-      (inherit icu4c)
-      (version "73.1")
-      (source (origin
-                (method url-fetch)
-                (uri (string-append
-                      "https://github.com/unicode-org/icu/releases/download/release-"
-                      (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
-                      "/icu4c-"
-                      (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
-                      "-src.tgz"))
-                (sha256
-                 (base32
-                  "0iccpdvc0kvpww5a31k9gjkqigyz016i7v80r9zamd34w4fl6mx4"))
-                (patches
-                 (cons
-                  (search-patch
-                   "icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch")
-                  (origin-patches (package-source icu4c)))))))))
-
 ;;;
 ;;; Localization helper procedures.
 ;;;
@@ -757,7 +732,7 @@  (define-public icecat-minimal
            ;; https://bugzilla.mozilla.org/show_bug.cgi?id=1819374).
            ffmpeg-5
            libvpx
-           (force icu4c-73-promise)
+           icu4c-73
            pixman
            pulseaudio
            mesa
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 5aaf3a8361..0dfe63b20a 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -109,6 +109,28 @@  (define-public icu4c
     (license x11)
     (home-page "http://site.icu-project.org/")))
 
+(define-public icu4c-73
+  (package
+    (inherit icu4c)
+    (name "icu4c")
+    (version "73.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/unicode-org/icu/releases/download/release-"
+                    (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
+                    "/icu4c-"
+                    (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
+                    "-src.tgz"))
+              (sha256
+               (base32
+                "0iccpdvc0kvpww5a31k9gjkqigyz016i7v80r9zamd34w4fl6mx4"))
+              (patches
+               (cons
+                (search-patch
+                 "icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch")
+                (origin-patches (package-source icu4c))))))))
+
 (define-public icu4c-70
   (package
     (inherit icu4c)