diff mbox series

[bug#66788,2/2] gnu: python-packaging: Update to 22.0.

Message ID 20240204125440.3508-2-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves Feb. 4, 2024, 12:54 p.m. UTC
* gnu/packages/python-xyz.scm (python-packaging): Update to 22.0.
---
 gnu/packages/python-xyz.scm | 29 ++++++++++-------------------
 1 file changed, 10 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5ffea67fc9..b1d2923595 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23500,25 +23500,16 @@  (define-public python-gtts
 (define-public python-packaging
   (package/inherit python-packaging-bootstrap
     (name "python-packaging")
-    (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (if tests?
-                          (invoke "pytest" "-vv")
-                          (format #t "test suite not run~%")))))))
-    (native-inputs (list python-pretend python-pytest))
-    (propagated-inputs (list python-pyparsing python-six))
-    (home-page "https://github.com/pypa/packaging")
-    (synopsis "Core utilities for Python packages")
-    (description "Packaging is a Python module for dealing with Python packages.
-     It offers an interface for working with package versions, names, and dependency
-     information.")
-    ;; From 'LICENSE': This software is made available under the terms of
-    ;; *either* of the licenses found in LICENSE.APACHE or LICENSE.BSD.
-    ;; Contributions to this software is made under the terms of *both* these
-    ;; licenses.
-    (license (list license:asl2.0 license:bsd-2))))
+    (version "22.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "packaging" version))
+       (sha256
+        (base32 "1lygw8fw9qj8md86g0ckzp16y1qlhw60zq0pjy7pn0acplhfr611"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pretend python-pytest python-flit-core))
+    (propagated-inputs (list python-pyparsing python-six))))
 
 (define-public python-relatorio
   (package