diff mbox series

[bug#68873,1/3] gnu: linux-libre 6.7: Update to 6.7.3.

Message ID 20240201150927.11453-1-w@wmeyer.eu
State New
Headers show
Series linux-libre kernel updates (2024-02-01) | expand

Commit Message

Wilko Meyer Feb. 1, 2024, 3:09 p.m. UTC
* gnu/packages/linux.scm (linux-libre-6.7-version): Update to 6.7.3.
(linux-libre-6.7-pristine-source): Update hash.
---
 gnu/packages/linux.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Feb. 6, 2024, 2:07 a.m. UTC | #1
On Thu, Feb 01, 2024 at 04:09:21PM +0100, Wilko Meyer wrote:
> * gnu/packages/linux.scm (linux-libre-6.7-version): Update to 6.7.3.
> (linux-libre-6.7-pristine-source): Update hash.

Thanks! Pushed as a4464bd0975c811f18af98f69032b29bddda5b81

I noticed that the documentation package for 6.6.15 failed to build with
some Sphinx error:

https://ci.guix.gnu.org/build/3393605/details

------
starting phase `build'
  PARSE   include/uapi/linux/dvb/ca.h
  PARSE   include/uapi/linux/dvb/dmx.h
  PARSE   include/uapi/linux/dvb/frontend.h
  PARSE   include/uapi/linux/dvb/net.h
  PARSE   include/uapi/linux/videodev2.h
  PARSE   include/uapi/linux/media.h
  PARSE   include/uapi/linux/cec.h
  PARSE   include/uapi/linux/lirc.h
Using alabaster theme

Sphinx parallel build error:
UnboundLocalError: local variable 'fname' referenced before assignment
make[2]: *** [Documentation/Makefile:113: texinfodocs] Error 2
make[1]: *** [/tmp/guix-build-linux-libre-documentation-6.6.15.drv-0/linux-6.6.15/Makefile:1697: infodocs] Error 2
make: *** [Makefile:234: __sub-make] Error 2
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("infodocs" "-j" "24") exit-status: 2 term-signal: #f stop-signal: #f> 
phase `build' failed after 2.3 seconds
command "make" "infodocs" "-j" "24" failed with status 2
builder for `/gnu/store/1zh0xlpwdi05hanh9jdkxiyla1073lah-linux-libre-documentation-6.6.15.drv' failed with exit code 1
@ build-failed /gnu/store/1zh0xlpwdi05hanh9jdkxiyla1073lah-linux-libre-documentation-6.6.15.drv - 1 builder for `/gnu/store/1zh0xlpwdi05hanh9jdkxiyla1073lah-linux-libre-documentation-6.6.15.drv' failed with exit code 1
------

Hopefully it goes away in the next release.
Wilko Meyer Feb. 6, 2024, 10:11 a.m. UTC | #2
Hi Leo,

Leo Famulari <leo@famulari.name> writes:

> Thanks! Pushed as a4464bd0975c811f18af98f69032b29bddda5b81

Thanks for pushing/reviewing!

> I noticed that the documentation package for 6.6.15 failed to build with
>
> Hopefully it goes away in the next release.

We'll luckily be able to check this later on, there has been a new
series of 6.x updates yesterday (e.g. 6.6.16, 6.7.4 and 6.1.77) I'll
submit the patches within the next hours. If the docs error remains I'd
likely try to spend time in figuring out wether that's an upstream bug
and if it already has been reported.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e748b2cb8e..6ca3652664 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -495,7 +495,7 @@  (define (%upstream-linux-source version hash)
 
 ;; The current "mainline" kernel.
 
-(define-public linux-libre-6.7-version "6.7.2")
+(define-public linux-libre-6.7-version "6.7.3")
 (define-public linux-libre-6.7-gnu-revision "gnu")
 (define deblob-scripts-6.7
   (linux-libre-deblob-scripts
@@ -505,7 +505,7 @@  (define deblob-scripts-6.7
    (base32 "1vb2pd0wdfl9p5qi8hj1i5xg1p4pyrp01iqhap9xbb2yai4l80j5")))
 (define-public linux-libre-6.7-pristine-source
   (let ((version linux-libre-6.7-version)
-        (hash (base32 "0wd6pxh7wy9bzjzwd0rdsdnghpr53qbs722fhg07bi19m8dy8kf3")))
+        (hash (base32 "0i1bfkawyp917d9v3qa5nqzspzr3ixx7scbfl8x4lms74xjqrw5p")))
    (make-linux-libre-source version
                             (%upstream-linux-source version hash)
                             deblob-scripts-6.7)))