diff mbox series

[bug#68763,6/7] gnu: Add go-structlayout-pretty.

Message ID 20240127172428.18351-6-ngraves@ngraves.fr
State New
Headers show
Series [bug#68763,1/7] gnu: Remove go-github-com-kisielk-gotool. | expand

Commit Message

Nicolas Graves Jan. 27, 2024, 5:24 p.m. UTC
* gnu/packages/golang-check.scm (go-structlayout-pretty): New variable.

Change-Id: I622a991b12708ee52eb412a3c6b3fbeeb512843d
---
 gnu/packages/golang-check.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 3bfc7e679f..b767fc3254 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -135,6 +135,18 @@  (define-public go-structlayout-optimize
 reorders fields to minimize the amount of padding.  It can emit JSON to feed
 into @code{go-structlayout-pretty}.")))
 
+(define-public go-structlayout-pretty
+  (package
+    (inherit go-honnef-co-go-tools)
+    (name "go-structlayout-pretty")
+    (arguments
+     `(#:import-path "honnef.co/go/tools/cmd/structlayout-pretty"
+       #:unpack-path "honnef.co/go/tools"
+       #:install-source? #f))
+    (synopsis "Format the output of go-structlayout with ASCII art in Go.")
+    (description "This package takes @code{go-structlayout}-like JSON and
+prints an ASCII fraphic representing the memory layout.")))
+
 (define-public go-github-com-alecthomas-assert
   (let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
         (revision "1"))