diff mbox series

[bug#68735] gnu: Add python-gguf.

Message ID 20240126121400.9946-1-david@pflug.io
State New
Headers show
Series [bug#68735] gnu: Add python-gguf. | expand

Commit Message

David Pflug Jan. 26, 2024, 12:12 p.m. UTC
* gnu/packages/machine-learning.scm (python-gguf): New variable.

Needed for llama-cpp update (In #68455).

Change-Id: Icf6138486cccc5b4c3141424baccf17c4edb3449
---
 gnu/packages/machine-learning.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: cdf1d7dded027019f0ebbd5d6f0147b13dfdd28d

Comments

Ricardo Wurmus Jan. 26, 2024, 2:28 p.m. UTC | #1
Hi David,

thanks for the patch.

Why do you delete the check phase?  When tests are to be disabled please
use “#:tests? #false”.  If no tests are included in the Pypi tarball,
please fetch the code from the upstream repository instead.

Please use a plain list for the arguments field.

Please also use complete sentences in the description field.
David Pflug Jan. 26, 2024, 4:12 p.m. UTC | #2
Hi Ricardo,

Thanks for the feedback. I'd been trying to skip tests because upstream only provides a stub: https://github.com/ggerganov/llama.cpp/blob/master/gguf-py/tests/test_gguf.py

I'll prep a v2 with the requested changes.

Warm Regards,

David
Andreas Enge Feb. 11, 2024, 8:27 a.m. UTC | #3
Pushed as commit b6439fc5f800b5d22d48192bc347be794f050329 after adding the
first line of the commit message and a comment to explain why tests are
disabled, and turning the synopsis into a complete sentence.

QA suggests to put python-pytest into native instead of regular inputs;
but "guix gc --references" shows that the package retains references
to python-pytest and to poetry, so I kept them where they are.

Ricardo, please feel free to correct me.

Thanks for the patch, David!

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 3a12eb8c2f..0e88f7265b 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2023 Navid Afkhami <navid.afkhami@mdc-berlin.de>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 David Pflug <david@pflug.io>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5277,3 +5278,25 @@  (define-public oneapi-dnnl
      "OneAPI Deep Neural Network Library (oneDNN) is a cross-platform
 performance library of basic building blocks for deep learning applications.")
     (license license:asl2.0)))
+
+(define-public python-gguf
+  (package
+    (name "python-gguf")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gguf" version))
+       (sha256
+        (base32 "0rbyc2h3kpqnrvbyjvv8a69l577jv55a31l12jnw21m1lamjxqmj"))))
+    (build-system pyproject-build-system)
+    (arguments
+      `(#:phases
+        (modify-phases %standard-phases
+                       (delete 'check))))
+    (inputs (list poetry python-pytest))
+    (propagated-inputs (list python-numpy))
+    (home-page "https://ggml.ai")
+    (synopsis "Read and write ML models in GGUF for GGML")
+    (description "Read and write ML models in GGUF for GGML")
+    (license license:expat)))