diff mbox series

[bug#68640] gnu: Add font-oswald.

Message ID 20240121164758.20041-1-sirgazil@zoho.com
State New
Headers show
Series [bug#68640] gnu: Add font-oswald. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Jan. 21, 2024, 4:47 p.m. UTC
From: Luis Felipe <sirgazil@zoho.com>

* gnu/packages/fonts.scm (font-oswald): New variable.

Change-Id: Ief63b944b722d5ed1b3cabd041bcd75948a1f59e
---
 gnu/packages/fonts.scm | 30 +++++++++++++++++++++++++++++-
 1 file changed, 29 insertions(+), 1 deletion(-)


base-commit: 121de47decc1029c06f6e46e5f06d7fefe8e85ec

Comments

Ludovic Courtès Feb. 5, 2024, 9:46 p.m. UTC | #1
Hey Luis,

sirgazil@zoho.com skribis:

> From: Luis Felipe <sirgazil@zoho.com>
>
> * gnu/packages/fonts.scm (font-oswald): New variable.
>
> Change-Id: Ief63b944b722d5ed1b3cabd041bcd75948a1f59e

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e050f4fde9..f0e1e16cf4 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -58,7 +58,7 @@ 
 ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2023 chris <chris@bumblehead.com>
-;;; Copyright © 2023 Luis Felipe López Acevedo <sirgazil@zoho.com>
+;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <sirgazil@zoho.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3521,3 +3521,31 @@  (define-public font-orbitron
 and black), a stylistic alternative, small caps, and many alternate
 glyphs.")
       (license license:silofl1.1))))
+
+(define-public font-oswald
+  (let ((version "0")
+        (commit "6e65651c229e897dc55fb8d17097ee7f75b2769b")
+        (revision "0"))
+    (package
+      (name "font-oswald")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/googlefonts/OswaldFont")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0m5c98crw6df6hbhxv4smh6ldzk5fx434fyri8xgnsjjcrkqxy0h"))))
+      (build-system font-build-system)
+      (home-page "https://github.com/googlefonts/OswaldFont")
+      (synopsis "Gothic typeface")
+      (description "Oswald is a reworking of the classic gothic typeface
+style historically represented by designs such as 'Alternate Gothic'.
+The characters of Oswald have been re-drawn and reformed to better fit
+the pixel grid of standard digital screens.  Oswald is designed to be
+used freely across the internet by web browsers on desktop computers,
+laptops and mobile devices.")
+      (license license:silofl1.1))))