diff mbox series

[bug#68603] gnu: Add java-jakartaee-jaf-api-2.1.2.

Message ID 20240119221706.4705-1-adam.m.kandur@gmail.com
State New
Headers show
Series [bug#68603] gnu: Add java-jakartaee-jaf-api-2.1.2. | expand

Commit Message

Adam Kandur Jan. 19, 2024, 10:17 p.m. UTC
* gnu/packages/java.scm (java-jakartaee-jaf-api-2.1.2): New variable.
---
 gnu/packages/java.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index a6d55aa..51fdcc3 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -12415,6 +12415,33 @@  (define-public java-jakarta-regexp
 generator for Java.")
     (license license:asl2.0)))
 
+(define-public java-jakartaee-jaf-api-2.1.2
+  (package
+    (name "java-jakartaee-jaf-api")
+    (version "2.1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jakartaee/jaf-api")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1k9l56512jwd2kgqv36jyhnif6q850l59wyx1cmypib01rdfj3nv"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "jakarta.activation-api.jar"
+       #:source-dir "api/src/main/java"
+       #:jdk ,openjdk11
+       #:tests? #f))
+    (inputs (list java-httpcomponents-httpclient))
+    (home-page "https://jakartaee.github.io/jaf-api")
+    (synopsis "Jakarta Activation Specification project")
+    (description "Jakarta EE gives developers a comprehensive set of vendor neutral, open specifications that are used for developing modern, cloud native Java applications from the ground up.  With Jakarta EE, technology developers and consumers can be confident they have the best technologies for developing cloud native, mission-critical applications.  And they can build on decades of Java developer expertise to move existing workloads to the cloud.")
+    (license license:bsd-3)))
+
+(define-public java-jakartaee-jaf-api java-jakartaee-jaf-api-2.1.2)
+
 (define-public java-jline
   (package
     (name "java-jline")