diff mbox series

[bug#68575,core-updates,1/3] gnu: icedtea-7: Fix build.

Message ID 20240118215935.5178-1-code@greghogan.com
State New
Headers show
Series Fix openjdk build. | expand

Commit Message

Greg Hogan Jan. 18, 2024, 9:59 p.m. UTC
* gnu/packages/java.scm (icedtea-7)[arguments]: Use C.UTF-8 locale in
'install-keystore phase.

Change-Id: I6da65dd8aaea6fc95f7f0d269ed5ab45c26ce21d
---
 gnu/packages/java.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 5e910e9749..ce75c1cadb 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -577,8 +577,8 @@  (define (import-cert cert)
 
                  ;; This is necessary because the certificate directory contains
                  ;; files with non-ASCII characters in their names.
-                 (setlocale LC_ALL "en_US.utf8")
-                 (setenv "LC_ALL" "en_US.utf8")
+                 (setlocale LC_ALL "C.UTF-8")
+                 (setenv "LC_ALL" "C.UTF-8")
 
                  (for-each import-cert (find-files certs-dir "\\.pem$"))
                  (mkdir-p (string-append (assoc-ref outputs "out")