diff mbox series

[bug#68552] gnu: Add duckdb.

Message ID 20240117214918.70863-1-code@greghogan.com
State New
Headers show
Series [bug#68552] gnu: Add duckdb. | expand

Commit Message

Greg Hogan Jan. 17, 2024, 9:49 p.m. UTC
There exists a package python-duckdb, and this patch adds a package for
the CLI and C++ libraries.

* gnu/packages/cpp.scm (duckdb): New variable.
---
 gnu/packages/cpp.scm | 29 ++++++++++++++++++++++++++++-
 1 file changed, 28 insertions(+), 1 deletion(-)


base-commit: 692272661548eb2a46aaa818175b1a39b3fc9ffa

Comments

Sharlatan Hellseher Jan. 20, 2024, 12:48 p.m. UTC | #1
Hi,

Thank you for the patch.

There is one minor lint warnings in QA, and maybe it more suitable for
databases module (based on description)?

Thanks,
Oleg
Sharlatan Hellseher Feb. 14, 2024, 12:13 p.m. UTC | #2
Hi Greg,

I've pushed it as 3fa4a8baf3fb735a09ed915abd4f61600e2d77e2 to master.

There is a new released published on 2024-02-13
https://github.com/duckdb/duckdb/releases/tag/v0.10.0. I tried to update
it but it requires more work as it failed to build.

If you have some spare time, may you take a look at it please?

Thanks,
Oleg
Greg Hogan Feb. 14, 2024, 1:54 p.m. UTC | #3
On Wed, Feb 14, 2024 at 7:13 AM Sharlatan Hellseher
<sharlatanus@gmail.com> wrote:
>
>
> Hi Greg,
>
> I've pushed it as 3fa4a8baf3fb735a09ed915abd4f61600e2d77e2 to master.
>
> There is a new released published on 2024-02-13
> https://github.com/duckdb/duckdb/releases/tag/v0.10.0. I tried to update
> it but it requires more work as it failed to build.
>
> If you have some spare time, may you take a look at it please?
>
> Thanks,
> Oleg

Oleg,

Thanks for the commit. I happened upon the update yesterday and also
tried the simple version update, hitting the same issue as you. I'll
try to look at it again sometime.

Greg
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ecd3e4afac..420d9e8708 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -14,7 +14,7 @@ 
 ;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
-;;; Copyright © 2020-2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2020-2022, 2024 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Milkey Mouse <milkeymouse@meme.institute>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
@@ -3064,3 +3064,30 @@  (define-public tl-optional
 the std::optional for C++11/14/17, with support for monadic operations added in
 C++23.")
     (license license:cc0)))
+
+(define-public duckdb
+  (package
+    (name "duckdb")
+    (version "0.9.2")
+    (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/duckdb/duckdb")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0dbsxyiz7c8sxflbfj87qv0b2s69zk802vsk5h00ra8w8fcbqlj0"))
+       (modules '((guix build utils)))
+       (snippet
+        #~(begin
+            ;; There is no git checkout from which to read the version tag.
+            (substitute* "CMakeLists.txt"
+              (("set\\(DUCKDB_VERSION \"[^\"]*\"")
+               (string-append "set(DUCKDB_VERSION \"v" #$version "-dev0\"")))))))
+    (build-system cmake-build-system)
+    (synopsis "DuckDB embedded database")
+    (description "DuckDB is an in-process SQL OLAP database management system.")
+    (home-page "https://duckdb.org")
+    (license license:expat)))