diff mbox series

[bug#68533] gnu: python-scikit-learn-extra: Update to 0.3.0-0f95d8d.

Message ID 20240117160219.13336-1-code@greghogan.com
State New
Headers show
Series [bug#68533] gnu: python-scikit-learn-extra: Update to 0.3.0-0f95d8d. | expand

Commit Message

Greg Hogan Jan. 17, 2024, 4:02 p.m. UTC
Includes patch from upstream to fix test error building against recently
updated sklearn to 1.3 as described in
https://github.com/scikit-learn-contrib/scikit-learn-extra/issues/171

* gnu/packages/machine-learning.scm (python-scikit-learn-extra): Update
to 0.3.0-0f95d8d.

Change-Id: Ie5137497484dc18f3815bddb2299bcbd4e11b1e9
---
 gnu/packages/machine-learning.scm | 88 ++++++++++++++++---------------
 1 file changed, 45 insertions(+), 43 deletions(-)


base-commit: 604ff7e28eead3ae8bd5e27136565e619a89e744

Comments

Greg Hogan Jan. 24, 2024, 2:59 p.m. UTC | #1
Fixed in 6a22f65d661d65491bab2fc45da8ed6d6414f5ff
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1540018347..5b0445a6b9 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1670,52 +1670,54 @@  (define-public python-scikit-learn
     (license license:bsd-3)))
 
 (define-public python-scikit-learn-extra
-  (package
-    (name "python-scikit-learn-extra")
-    (version "0.3.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/scikit-learn-contrib/scikit-learn-extra")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0yy6ka94ss88f3r7b6mpjf1l8lnv7aabhsg844pigfj8lfiv0wvl"))))
-    (build-system pyproject-build-system)
-    (arguments
-     (list #:phases
-           #~(modify-phases %standard-phases
-               (add-after 'build 'build-ext
-                 (lambda _
-                   (invoke "python" "setup.py" "build_ext"
-                           "--inplace")))
-               (replace 'check
-                 (lambda* (#:key tests? #:allow-other-keys)
-                   (when tests?
-                     ;; Restrict OpenBLAS threads to prevent segfaults while testing!
-                     (setenv "OPENBLAS_NUM_THREADS" "1")
-
-                     ;; Some tests require write access to $HOME.
-                     (setenv "HOME" "/tmp")
-
-                     ;; Step out of the source directory to avoid interference;
-                     ;; we want to run the installed code with extensions etc.
-                     (with-directory-excursion "/tmp"
-                       (invoke "pytest" "-vv" "--pyargs"
-                               "sklearn_extra"
-                               ;; ignore tests that require network
-                               "-k" "not test_build"))))))))
-    (propagated-inputs (list python-numpy python-scikit-learn python-scipy))
-    (native-inputs (list python-pytest python-pytest-cov python-cython))
-    (home-page "https://github.com/scikit-learn-contrib/scikit-learn-extra")
-    (synopsis "Set of tools for scikit-learn")
-    (description
-     "This package provides a Python module for machine learning that extends
+  (let* ((commit "0f95d8dda4c69f9de4fb002366041adcb1302f3b")
+         (revision "0"))
+    (package
+      (name "python-scikit-learn-extra")
+      (version (git-version "0.3.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/scikit-learn-contrib/scikit-learn-extra")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0a248sff1psfwzmngj465gzyisq20d83nzpwpq2cspxhih51m6j9"))))
+      (build-system pyproject-build-system)
+      (arguments
+       (list #:phases
+             #~(modify-phases %standard-phases
+                 (add-after 'build 'build-ext
+                   (lambda _
+                     (invoke "python" "setup.py" "build_ext"
+                             "--inplace")))
+                 (replace 'check
+                   (lambda* (#:key tests? #:allow-other-keys)
+                     (when tests?
+                       ;; Restrict OpenBLAS threads to prevent segfaults while testing!
+                       (setenv "OPENBLAS_NUM_THREADS" "1")
+  
+                       ;; Some tests require write access to $HOME.
+                       (setenv "HOME" "/tmp")
+  
+                       ;; Step out of the source directory to avoid interference;
+                       ;; we want to run the installed code with extensions etc.
+                       (with-directory-excursion "/tmp"
+                         (invoke "pytest" "-vv" "--pyargs"
+                                 "sklearn_extra"
+                                 ;; ignore tests that require network
+                                 "-k" "not test_build"))))))))
+      (propagated-inputs (list python-numpy python-scikit-learn python-scipy))
+      (native-inputs (list python-pytest python-pytest-cov python-cython))
+      (home-page "https://github.com/scikit-learn-contrib/scikit-learn-extra")
+      (synopsis "Set of tools for scikit-learn")
+      (description
+       "This package provides a Python module for machine learning that extends
 scikit-learn.  It includes algorithms that are useful but do not satisfy the
 scikit-learn inclusion criteria, for instance due to their novelty or lower
 citation number.")
-    (license license:bsd-3)))
+      (license license:bsd-3))))
 
 (define-public python-thinc
   (package