diff mbox series

[bug#68489,1/2] gnu: Add python-pytest-tornado5.

Message ID 20240115224454.28915-1-goodoldpaul@autistici.org
State New
Headers show
Series [bug#68489,1/2] gnu: Add python-pytest-tornado5. | expand

Commit Message

Giacomo Leidi Jan. 15, 2024, 10:44 p.m. UTC
* gnu/packages/check.scm (python-pytest-tornado5): New variable.

Change-Id: I9843e91d750bf17128eb6f566b8dbb5cbc0d8278
---
 gnu/packages/check.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 19db1551dc6f6180d2cda9084c2dec37bf4923c9

Comments

Giacomo Leidi Jan. 15, 2024, 10:47 p.m. UTC | #1
This issue was opened by mistake, apologies for the noise
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b475aea8ae..49a5f42ca8 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -48,6 +48,7 @@ 
 ;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3573,6 +3574,29 @@  (define-public python-pytest-regressions
 that can be used to verify that future runs produce the same data.")
     (license license:expat)))
 
+(define-public python-pytest-tornado5
+  (package
+    (name "python-pytest-tornado5")
+    (version "2.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pytest-tornado5" version))
+              (sha256
+               (base32
+                "0qb62jw2w0xr6y942yp0qxiy755bismjfpnxaxjjm05gy2pymr8d"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; Tests require pytest < 6
+     (list #:tests? #f))
+    (propagated-inputs (list python-pytest python-tornado))
+    (home-page "https://github.com/vidartf/pytest-tornado")
+    (synopsis
+     "Fixtures and markers to simplify testing of Tornado applications")
+    (description
+     "This package provides a @code{py.test} plugin providing fixtures and markers to
+simplify testing of asynchronous tornado applications.")
+    (license license:asl2.0)))
+
 (define-public guile-proba
   (package
     (name "guile-proba")