diff mbox series

[bug#68457,v4,4/6] gnu: python-jupytext: Update to 1.15.2.

Message ID 20240114235609.24296-4-goodoldpaul@autistici.org
State New
Headers show
Series [bug#68456,v4,1/6] gnu: Add python-pygments-2.16. | expand

Commit Message

Giacomo Leidi Jan. 14, 2024, 11:56 p.m. UTC
* gnu/packages/python-xyz.scm (python-jupytext): Update to 1.15.2;
[build-system]: switch to pyproject-build-system;
[arguments]<phases>: add setup-test-environment phase, use check phase
from build system and move test flags from here...
<test-flags>: ... to here.

Change-Id: Iaec4090823715230e26865d4639871fb7c565802
---
 gnu/packages/python-xyz.scm | 26 +++++++++++---------------
 1 file changed, 11 insertions(+), 15 deletions(-)

Comments

Giacomo Leidi Jan. 15, 2024, 12:05 a.m. UTC | #1
This issue was opened by mistake, apologies for the noise.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cef458e0fc..b4b95637c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -336,7 +336,7 @@  (define-public python-janus
 (define-public python-jupytext
   (package
     (name "python-jupytext")
-    (version "1.14.4")
+    (version "1.15.2")
     (source
      (origin
        (method git-fetch)
@@ -345,27 +345,23 @@  (define-public python-jupytext
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "19d443vx597zzxna09qpync9iic3mris80bwm3kd8xaxaq0zq9w4"))))
-    (build-system python-build-system)
+        (base32 "0zi2b2g9b2dkzl69li5rwc17pdcxj8cxzlysd8s6jqbcc37jiwqs"))))
+    (build-system pyproject-build-system)
     (arguments
      (list
+      #:test-flags
+      #~'("-k" #$(string-join (list "not test_create_header_with_set_formats"
+                                    "test_pre_commit_hook"
+                                    "test_sync_with_pre_commit_hook")
+                              " and not "))
       #:phases
       #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
+          (add-before 'check 'setup-test-environment
+            (lambda _
               ;; some tests fail when HOME=/homeless-shelter.
               (setenv "HOME" "/tmp")
               ;; OSError: [Errno 18] Invalid cross-device link
-              (setenv "TMPDIR" "/tmp")
-              (when tests?
-                (let ((disabled-tests
-                       (list "test_create_header_with_set_formats"
-                             "test_pre_commit_hook"
-                             "test_sync_with_pre_commit_hook")))
-                  (invoke "pytest" "-vv" "-k"
-                          (string-append "not "
-                                         (string-join disabled-tests
-                                                      " and not "))))))))))
+              (setenv "TMPDIR" "/tmp"))))))
     (native-inputs
      (list git-minimal
            pre-commit