diff mbox series

[bug#68295] gnu: txt2tags: Update to 3.9.

Message ID 20240106192830.600148-1-kiasoc5@disroot.org
State New
Headers show
Series [bug#68295] gnu: txt2tags: Update to 3.9. | expand

Commit Message

kiasoc5 Jan. 6, 2024, 7:28 p.m. UTC
* gnu/packages/textutils.scm (txt2tags): Update to 3.9.
[native-inputs]: Remove python-tox.

Change-Id: Ia825f5807c87941504feffdb317594f5b1fa62ef
---
 gnu/packages/textutils.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)


base-commit: c0e21e523d93081153a2ffc91e5a9f06afe62b91

Comments

Mathieu Othacehe Jan. 7, 2024, 6:51 p.m. UTC | #1
> [native-inputs]: Remove python-tox.

I restored that native-inputs, otherwise I have the following failure:

--8<---------------cut here---------------start------------->8---
ERROR: No matching distribution found for tox
error: Command '['/gnu/store/375350pi1l1izgnx6dnsqmg4xjyprx8q-python-wrapper-3.10.7/bin/python', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/guix-build-txt2tags-3.9.drv-0/tmpohrsiiyw', '--quiet', 'tox']' returned non-zero exit status 1.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test") exit-status: 1 term-signal: #f stop-signal: #f> 
phase `check' failed after 8.1 seconds
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with status 1
builder for `/gnu/store/nlcgcbi9b0jlsbjz2cyrl5nqkd92j0ql-txt2tags-3.9.drv' failed with exit code 1
@ build-failed /gnu/store/nlcgcbi9b0jlsbjz2cyrl5nqkd92j0ql-txt2tags-3.9.drv - 1 builder for `/gnu/store/nlcgcbi9b0jlsbjz2cyrl5nqkd92j0ql-txt2tags-3.9.drv' failed with exit code 1
derivation '/gnu/store/nlcgcbi9b0jlsbjz2cyrl5nqkd92j0ql-txt2tags-3.9.drv' offloaded to '10.10.10.3' failed: build of `/gnu/store/nlcgcbi9b0jlsbjz2cyrl5nqkd92j0ql-txt2tags-3.9.drv' failed
--8<---------------cut here---------------end--------------->8---

and applied.

Thanks,

Mathieu
kiasoc5 Jan. 7, 2024, 8:11 p.m. UTC | #2
On 1/7/24 13:51, Mathieu Othacehe wrote:
> 
>> [native-inputs]: Remove python-tox.
> 
> I restored that native-inputs, otherwise I have the following failure:


Thanks! Didn't realize that guix refresh would delete the native input.
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index ea182b1925..91ba616087 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -996,15 +996,15 @@  (define-public python-editdistance
 (define-public txt2tags
   (package
     (name "txt2tags")
-    (version "3.7")
+    (version "3.9")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "txt2tags" version))
               (sha256
                (base32
-                "12hpnvdy7dgarq6ini9jp7dp2zcmvpax04zbl3jb84kd423r75i7"))))
+                "0ik7gpr3gymgxnj0p86k8768kyxncbncv93zq67sbak3dbdl8hky"))))
     (build-system python-build-system)
-    (native-inputs (list python-tox))
+    (native-inputs (list))
     (home-page "https://txt2tags.org")
     (synopsis "Convert between markup languages")
     (description