diff mbox series

[bug#68026] gnu: gthumb: Improve style.

Message ID 20231225151727.8211-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#68026] gnu: gthumb: Improve style. | expand

Commit Message

Nicolas Graves Dec. 25, 2023, 3:17 p.m. UTC
* gnu/packages/gnome.scm (gthumb):
[arguments]: Use gexp.
[native-inputs]: Rewrite using list.
[inputs]: Rewrite using list.

Change-Id: I925c3ac0ebef89534608926545309ff232e2af01
---
 gnu/packages/gnome.scm | 58 ++++++++++++++++++++----------------------
 1 file changed, 28 insertions(+), 30 deletions(-)

Comments

Mathieu Othacehe Dec. 27, 2023, 8:55 p.m. UTC | #1
> * gnu/packages/gnome.scm (gthumb):
> [arguments]: Use gexp.
> [native-inputs]: Rewrite using list.
> [inputs]: Rewrite using list.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b0417b2df9..566bf99f0e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11812,38 +11812,36 @@  (define-public gthumb
                 "09flm8s6jrvfya2ypw5873mnnani8ssy7wdv3ra1cljk4bjszy4p"))))
     (build-system meson-build-system)
     (arguments
-     `(#:glib-or-gtk? #t
-       #:configure-flags
-       ;; Ensure the RUNPATH contains all installed library locations.
-       (list (string-append "-Dc_link_args=-Wl,-rpath="
-                            (assoc-ref %outputs "out")
-                            "/lib/gthumb/extensions")
-             (string-append "-Dcpp_link_args=-Wl,-rpath="
-                            (assoc-ref %outputs "out")
-                            "/lib/gthumb/extensions"))))
+     (list
+      #:glib-or-gtk? #t
+      #:configure-flags
+      ;; Ensure the RUNPATH contains all installed library locations.
+      #~(list (string-append "-Dc_link_args=-Wl,-rpath=" #$output
+                             "/lib/gthumb/extensions")
+              (string-append "-Dcpp_link_args=-Wl,-rpath=" #$output
+                             "/lib/gthumb/extensions"))))
     (native-inputs
-     `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
-       ("glib:bin" ,glib "bin")                   ; for glib-compile-resources
-       ("gtk+:bin" ,gtk+ "bin")                   ; for gtk-update-icon-cache
-       ("intltool" ,intltool)
-       ("itstool" ,itstool)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python)))
+     (list desktop-file-utils   ; for update-desktop-database
+           `(,glib "bin")       ; for glib-compile-resources
+           `(,gtk+ "bin")       ; for gtk-update-icon-cache
+           intltool
+           itstool
+           pkg-config
+           python))
     (inputs
-     `(("clutter" ,clutter)
-       ("clutter-gst" ,clutter-gst)
-       ("clutter-gtk" ,clutter-gtk)
-       ("colord" ,colord)
-       ("exiv2" ,exiv2)
-       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-       ("gstreamer" ,gstreamer)
-       ("gtk" ,gtk+)
-       ("libheif" ,libheif)
-       ("libjpeg" ,libjpeg-turbo)
-       ("libraw" ,libraw)
-       ("librsvg" ,(librsvg-for-system))
-       ("libtiff" ,libtiff)
-       ("libwebp" ,libwebp)))
+     (list clutter
+           clutter-gst
+           clutter-gtk
+           colord
+           exiv2
+           gsettings-desktop-schemas
+           gtk+
+           libheif
+           libjpeg-turbo
+           libraw
+           (librsvg-for-system)
+           libtiff
+           libwebp))
     (home-page "https://wiki.gnome.org/Apps/Gthumb")
     (synopsis "GNOME image viewer and browser")
     (description "GThumb is an image viewer, browser, organizer, editor and