diff mbox series

[bug#68024] Remove ocaml4.07 packages

Message ID 20231225121821.009eda51@tachikoma.lepiller.eu
State New
Headers show
Series [bug#68024] Remove ocaml4.07 packages | expand

Commit Message

Julien Lepiller Dec. 25, 2023, 11:18 a.m. UTC
Hi Guix!

I created a long patch series (67 patches) to remove ocaml 4.07
packages. The series keeps ocaml@4.07 itself, as well as findlib and
dune, so we can always build ocaml4.07 packages later if we want to (we
might need to build at least menhir, that will be required to build
ocaml>4.07)

I don't think it requires QA, since we're only removing packages.
Patches look like the attached patch. If you agree with this in
principle, I'll push the series this week.

I checked that each intermediate commit builds (no unbound variable),
used guix refresh to discover a proper order (removing leaf packages).
If you prefer, I can send the whole series.

Comments

pukkamustard Dec. 25, 2023, 6:58 p.m. UTC | #1
Hi!

Julien Lepiller <julien@lepiller.eu> writes:

> Hi Guix!
>
> I created a long patch series (67 patches) to remove ocaml 4.07
> packages. The series keeps ocaml@4.07 itself, as well as findlib and
> dune, so we can always build ocaml4.07 packages later if we want to (we
> might need to build at least menhir, that will be required to build
> ocaml>4.07)

+1

If you think it makes sense, you could also move the ocaml@4.07 to a new
ocaml-boot.scm. But this can also be done later when/if we split up
OCaml packages.

> I don't think it requires QA, since we're only removing packages.
> Patches look like the attached patch. If you agree with this in
> principle, I'll push the series this week.

I agree with the principle.

> I checked that each intermediate commit builds (no unbound variable),
> used guix refresh to discover a proper order (removing leaf packages).
> If you prefer, I can send the whole series.

Excellent. I trust your dilligence.

Thanks!
Julien Lepiller Dec. 30, 2023, 9:20 p.m. UTC | #2
Pushed to master as b8d1492647898d15f3367c868e3fc70524d8920d to
b8aea26c4f45dfb34deefe980c6d6002d6aa12f3. Thanks!
diff mbox series

Patch

From b5a46ee697742820e68a4689c20e419b74b60cc4 Mon Sep 17 00:00:00 2001
Message-ID: <b5a46ee697742820e68a4689c20e419b74b60cc4.1703502940.git.julien@lepiller.eu>
In-Reply-To: <42ca866dca866a942d641f3d369ad9657b92294f.1703502940.git.julien@lepiller.eu>
References: <42ca866dca866a942d641f3d369ad9657b92294f.1703502940.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Mon, 25 Dec 2023 11:04:29 +0100
Subject: [PATCH 33/67] gnu: Remove ocaml4.07-ppx-hash.

* gnu/packages/ocaml.scm (ocaml4.07-ppx-hash): Remove variable.
(ocaml-ppx-hash)[properties]: Remove variant.

Change-Id: I38a4e5a4deb88398ae714b0671c9477551e7b6d9
---
 gnu/packages/ocaml.scm | 21 +--------------------
 1 file changed, 1 insertion(+), 20 deletions(-)

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ac2da9cead..bbcf97ccb0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6897,32 +6897,13 @@  (define-public ocaml-ppx-hash
     (propagated-inputs
      (list ocaml-base ocaml-ppx-compare ocaml-ppx-sexp-conv
            ocaml-migrate-parsetree ocaml-ppxlib))
-    (properties `((upstream-name . "ppx_hash")
-                  (ocaml4.07-variant . ,(delay ocaml4.07-ppx-hash))))
+    (properties `((upstream-name . "ppx_hash")))
     (home-page "https://github.com/janestreet/ppx_hash")
     (synopsis "Generation of hash functions from type expressions and definitions")
     (description "This package is a collection of ppx rewriters that generate
 hash functions from type exrpessions and definitions.")
     (license license:asl2.0)))
 
-(define-public ocaml4.07-ppx-hash
-  (package-with-ocaml4.07
-   (package
-     (inherit ocaml-ppx-hash)
-     (name "ocaml-ppx-hash")
-     (home-page "https://github.com/janestreet/ppx_hash")
-     (version "0.11.1")
-     (source (origin
-               (method git-fetch)
-               (uri (git-reference
-                     (url home-page)
-                     (commit (string-append "v" version))))
-               (file-name (git-file-name name version))
-               (sha256
-                (base32
-                 "1p0ic6aijxlrdggpmycj12q3cy9xksbq2vq727215maz4snvlf5p"))))
-     (properties `((upstream-name . "ppx_hash"))))))
-
 (define-public ocaml-ppx-enumerate
   (package
     (name "ocaml-ppx-enumerate")
-- 
2.41.0