diff mbox series

[bug#67992] gnu: python-wand: Fix libmagick access.

Message ID 20231223153325.26379-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#67992] gnu: python-wand: Fix libmagick access. | expand

Commit Message

Nicolas Graves Dec. 23, 2023, 3:33 p.m. UTC
* gnu/packages/python-xyz.scm (python-wand):
[build-system]: Use pyproject-build-system.
[arguments](phases): Delete phase check. Replace phase find-magickwand
by phase harcode-lib-path.

Change-Id: I3ddf7045a404f76743c14a5b8183ce9f3196ffd1
---
 gnu/packages/python-xyz.scm | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

Comments

Mathieu Othacehe Jan. 12, 2024, 4:33 p.m. UTC | #1
> * gnu/packages/python-xyz.scm (python-wand):
> [build-system]: Use pyproject-build-system.
> [arguments](phases): Delete phase check. Replace phase find-magickwand
> by phase harcode-lib-path.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 69e9c7a04d..226c4de035 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2612,18 +2612,18 @@  (define-public python-wand
        (uri (pypi-uri "Wand" version))
        (sha256
         (base32 "1jpwm956vm35hmgjndr2jwrcql0bwvpsl88q5nr0x8ppxa2380gm"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'find-magickwand
-           (lambda* (#:key inputs #:allow-other-keys)
-             (setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
-             (setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16")))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv")))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'hardcode-lib-path
+            (lambda _
+              (substitute* "wand/api.py"
+                (("os\\.environ\\.get\\('MAGICK_HOME'\\)")
+                 (string-append "\"" #$(this-package-input "imagemagick") "\""))
+                (("os\\.environ\\.get\\('WAND_MAGICK_LIBRARY_SUFFIX'\\)")
+                 "\".Q16\"")))))))
     (native-inputs
      (list python-pytest))
     (inputs