diff mbox series

[bug#67859] gnu: libsigsegv: Fix x86_64 cross-compilation.

Message ID 20231216225802.17298-1-hello@lnikki.la
State New
Headers show
Series [bug#67859] gnu: libsigsegv: Fix x86_64 cross-compilation. | expand

Commit Message

Leo Nikkilä Dec. 16, 2023, 10:57 p.m. UTC
* gnu/packages/libsigsegv.scm (libsigsegv): Set `#:phases' for x86_64.
---
 gnu/packages/libsigsegv.scm | 19 +++++++++++++++++--
 1 file changed, 17 insertions(+), 2 deletions(-)

Comments

Mathieu Othacehe Dec. 23, 2023, 9:36 a.m. UTC | #1
Hello,

> +                         (add-before 'configure 'patch-x86_64-old-h
> +                           (lambda _
> +                             (substitute* "src/fault-linux-x86_64-old.h"
> +                               (("#include <asm/sigcontext\\.h>") ""))))))

That is almost the same fix as for MIPS so it could be
factorized. Couldn't we do that for all architectures in
src/fault-linux-xxx-old.h?

Is that issue reported upstream?

Thanks,

Mathieu
Mathieu Othacehe Jan. 7, 2024, 6:13 p.m. UTC | #2
Hello,

> That is almost the same fix as for MIPS so it could be
> factorized. Couldn't we do that for all architectures in
> src/fault-linux-xxx-old.h?

Efraim tooks care of it with 9816a5371663396bc092eb359222635e5675b174.

Closing, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/libsigsegv.scm b/gnu/packages/libsigsegv.scm
index ebbdd2ad90..39c76cd462 100644
--- a/gnu/packages/libsigsegv.scm
+++ b/gnu/packages/libsigsegv.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2023 Leo Nikkilä <hello@lnikki.la>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -41,6 +42,21 @@  (define-public libsigsegv
     `(;; The shared library isn't built by default but some packages need it.
       #:configure-flags '("--enable-shared")
 
+      ;; When cross-compiling for x86_64, work around this error:
+      ;;
+      ;; In file included from fault-linux-x86_64-old.h:17,
+      ;;    [...]
+      ;; linux-libre-headers-cross-x86_64-linux-gnu-5.15.49/include/asm/sigcontext.h:317:8: error: redefinition of ‘struct sigcontext’
+      ,@(if (string-contains (or (%current-target-system)
+                                 (%current-system))
+                             "x86_64")
+            `(#:phases (modify-phases %standard-phases
+                         (add-before 'configure 'patch-x86_64-old-h
+                           (lambda _
+                             (substitute* "src/fault-linux-x86_64-old.h"
+                               (("#include <asm/sigcontext\\.h>") ""))))))
+            '())
+
       ;; On MIPS, work around this error:
       ;;
       ;; In file included from fault-linux-mips-old.h:18:0,
@@ -52,8 +68,7 @@  (define-public libsigsegv
                          (add-before 'configure 'patch-mips-old-h
                            (lambda _
                              (substitute* "src/fault-linux-mips-old.h"
-                               (("#include <asm/sigcontext\\.h>") ""))
-                             #t))))
+                               (("#include <asm/sigcontext\\.h>") ""))))))
             '())))
    (description
     "GNU libsigsegv is a library to handle page faults, which occur when a