diff mbox series

[bug#67644] gnu: pypy: Update to 7.3.13.

Message ID 20231205195055.10424-1-code@greghogan.com
State New
Headers show
Series [bug#67644] gnu: pypy: Update to 7.3.13. | expand

Commit Message

Greg Hogan Dec. 5, 2023, 7:50 p.m. UTC
The validate-runpath error was previously reported in #57653.

Version update fixes the existing build errors.

* gnu/packages/python.scm (pypy3): Update to 7.3.13.
[source]: Update origin URI.
[arguments]<#:validate-runpath>: Disable check.
[arguments]<#:phases>: Update directory paths.

Change-Id: Ic6ab7dd77e30fa85d6fa5f000f9aa2528951b81e
---
 gnu/packages/pypy.scm | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/pypy.scm b/gnu/packages/pypy.scm
index c7c74c5c34..59c368417e 100644
--- a/gnu/packages/pypy.scm
+++ b/gnu/packages/pypy.scm
@@ -42,18 +42,19 @@  (define-module (gnu packages pypy)
 (define-public pypy
   (package
     (name "pypy")
-    (version "7.3.5")
+    (version "7.3.13")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://downloads.python.org/pypy/"
-                                  "pypy3.7-v" version "-src.tar.bz2"))
+                                  "pypy3.10-v" version "-src.tar.bz2"))
               (sha256
                (base32
-                "18lrdmpcczlbk3cfarkgwqdmilrybz56i1dafk8dkjlyk90gw86r"))))
+                "0v9s6pwrnaxqi5h1pvmaphj6kgyczx07ykl07hcx656h34y77haa"))))
     (build-system gnu-build-system)
     (arguments
      (list
       #:tests? #f                      ;FIXME: 43 out of 364 tests are failing
+      #:validate-runpath? #f
       #:modules '((ice-9 ftw) (ice-9 match)
                   (guix build utils) (guix build gnu-build-system))
       #:disallowed-references (list nss-certs)
@@ -151,7 +152,7 @@  (define-public pypy
                   (for-each
                    (lambda (x)
                      (delete-file-recursively (string-append
-                                               "lib-python/3/" x)))
+                                               "lib/pypy3.10/" x)))
                    '("tkinter/test"
                      "test"
                      "sqlite3/test"
@@ -161,12 +162,12 @@  (define-public pypy
                      "ctypes/test"
                      "unittest/test"))
                   ;; Patch shebang referencing python.
-                  (substitute* '("lib-python/3/cgi.py"
-                                 "lib-python/3/encodings/rot_13.py")
+                  (substitute* '("lib/pypy3.10/cgi.py"
+                                 "lib/pypy3.10/encodings/rot_13.py")
                     ((shebang-match-python) shebang-pypy3))
                   (with-fluids ((%default-port-encoding "ISO-8859-1"))
-                    (substitute* '("lib_pypy/_md5.py"
-                                   "lib_pypy/_sha1.py")
+                    (substitute* '("lib/pypy3.10/_md5.py"
+                                   "lib/pypy3.10/_sha1.py")
                       ((shebang-match-python) shebang-pypy3))))
                 (copy-recursively dist-dir #$output)))))))
     (native-inputs