diff mbox series

[bug#67494,v2] gnu: sysstat: Update to 12.7.4.

Message ID 20231204182251.2754-1-code@greghogan.com
State New
Headers show
Series [bug#67494,v2] gnu: sysstat: Update to 12.7.4. | expand

Commit Message

Greg Hogan Dec. 4, 2023, 6:22 p.m. UTC
v2: change origin to use git-fetch and update home-page to https.

* gnu/packages/linux.scm (sysstat): Update to 12.7.4.
[home-page]: Update URL.
---
 gnu/packages/linux.scm | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)

Comments

宋文武 Jan. 11, 2024, 12:41 p.m. UTC | #1
Greg Hogan <code@greghogan.com> writes:

> v2: change origin to use git-fetch and update home-page to https.
>
> * gnu/packages/linux.scm (sysstat): Update to 12.7.4.
> [home-page]: Update URL.

Adjust with: update to 12.7.5 and add gettext for NLS support.

Pushed to master, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 504d4a64a2..a8642424bd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7495,14 +7495,16 @@  (define-public efibootmgr
 (define-public sysstat
   (package
     (name "sysstat")
-    (version "12.4.4")
+    (version "12.7.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "http://pagesperso-orange.fr/sebastien.godard/"
-                           "sysstat-" version ".tar.xz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sysstat/sysstat")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "091xjip7l52dxal8dsfh5chksr4g9gclnssw3hjjxy84kr3yf4lm"))))
+        (base32 "09s1bychmvdiw5336chp2d1a1zd70n9zy67w32qg3wn9d76r5f8h"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no test suite.
@@ -7520,7 +7522,7 @@  (define-public sysstat
              (substitute* "Makefile"
                (("mkdir -p \\$\\(DESTDIR\\)\\$\\(SA_DIR\\)")
                 "")))))))
-    (home-page "http://sebastien.godard.pagesperso-orange.fr/")
+    (home-page "https://sysstat.github.io")
     (synopsis "Performance monitoring tools for Linux")
     (description "The sysstat utilities are a collection of performance
 monitoring tools for Linux.  These include @code{mpstat}, @code{iostat},