diff mbox series

[bug#66263,v1,20/22] gnu: lufa: Use AVR target.

Message ID 20231128113510.11214-20-jean@foundationdevices.com
State New
Headers show
Series None | expand

Commit Message

Jean-Pierre De Jesus DIAZ Nov. 28, 2023, 11:35 a.m. UTC
* gnu/packages/avr-xyz.scm (lufa): Remove AVR toolchain from inputs and
  use `#:target "avr"` keyword argument instead.

Change-Id: I792132a9211b1aa64283f9b4e76a4dd57e86646d
---
 gnu/packages/avr-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/avr-xyz.scm b/gnu/packages/avr-xyz.scm
index cc34189841..b14a0e7dfe 100644
--- a/gnu/packages/avr-xyz.scm
+++ b/gnu/packages/avr-xyz.scm
@@ -122,6 +122,7 @@  (define-public lufa
      ;; only built).
      (list
       #:tests? #f
+      #:target "avr"
       #:modules '((guix build gnu-build-system)
                   (guix build utils)
                   (ice-9 match)
@@ -172,7 +173,7 @@  (define-public lufa
                               (mkdir-p dest)
                               (copy-recursively html dest)))
                           html-dirs)))))))
-    (native-inputs (list doxygen (make-avr-toolchain)))
+    (native-inputs (list doxygen))
     (home-page "https://www.lufa-lib.org/")
     (synopsis "Lightweight USB Framework for AVRs")
     (description "UFA is a simple to use, lightweight framework which sits