diff mbox series

[bug#66263,v1,17/22] gnu: Add gcc-cross-avr-toolchain.

Message ID 20231128113510.11214-17-jean@foundationdevices.com
State New
Headers show
Series None | expand

Commit Message

Jean-Pierre De Jesus DIAZ Nov. 28, 2023, 11:35 a.m. UTC
* gnu/local.mk (GNU_SYSTEM_MODULES): Add cross-toolchain.scm.
* gnu/packages/cross-toolchain.scm (gcc-cross-avr-toolchain): New variable.

Change-Id: Ie768d5cc0663dd57753af1d4ac631b3cafbf9e8c
---
 gnu/local.mk                     |  1 +
 gnu/packages/cross-toolchain.scm | 36 ++++++++++++++++++++++++++++++++
 2 files changed, 37 insertions(+)
 create mode 100644 gnu/packages/cross-toolchain.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index a8142bb0f2..1360548e69 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -201,6 +201,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/crates-graphics.scm		\
   %D%/packages/crates-gtk.scm			\
   %D%/packages/cross-base.scm			\
+  %D%/packages/cross-toolchain.scm			\
   %D%/packages/crypto.scm			\
   %D%/packages/cryptsetup.scm			\
   %D%/packages/cups.scm				\
diff --git a/gnu/packages/cross-toolchain.scm b/gnu/packages/cross-toolchain.scm
new file mode 100644
index 0000000000..08511a7c00
--- /dev/null
+++ b/gnu/packages/cross-toolchain.scm
@@ -0,0 +1,36 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cross-toolchain)
+  #:use-module (gnu packages cross-base)
+  #:use-module (guix packages))
+
+;;; Commentary:
+;;;
+;;; This module provides packages for cross compilation toolchains.  These
+;;; packages must not be used at the top level to avoid cyclic module
+;;; dependencies caused by the (gnu packages cross-base) module referring to
+;;; to top level bindings from (gnu packages gcc).
+;;;
+;;; The real purpose of these packages is for installation on profiles by users
+;;; and other packages should make use of the toolchain through the usual cross
+;;; compilation methods. For example, by using the `#:target' argument on
+;;; packages or `--target' on the command line.
+
+(define-public gcc-cross-avr-toolchain
+  (cross-gcc-toolchain "avr"))