diff mbox series

[bug#67494] gnu: sysstat: Update to 12.7.4.

Message ID 20231127192515.96741-1-code@greghogan.com
State New
Headers show
Series [bug#67494] gnu: sysstat: Update to 12.7.4. | expand

Commit Message

Greg Hogan Nov. 27, 2023, 7:25 p.m. UTC
Deletion of the old home page was announced there before removal:
https://web.archive.org/web/20231003035440/http://sebastien.godard.pagesperso-orange.fr/

* gnu/packages/linux.scm (sysstat): Update to 12.7.4.
[source]: Update URI.
[home-page]: Likewise.

Change-Id: Ie839802b959e67dcc7405727290b67aa85818378
---
 gnu/packages/linux.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès Dec. 3, 2023, 10:47 p.m. UTC | #1
Greg Hogan <code@greghogan.com> skribis:

> Deletion of the old home page was announced there before removal:
> https://web.archive.org/web/20231003035440/http://sebastien.godard.pagesperso-orange.fr/
>
> * gnu/packages/linux.scm (sysstat): Update to 12.7.4.
> [source]: Update URI.
> [home-page]: Likewise.
>
> Change-Id: Ie839802b959e67dcc7405727290b67aa85818378

[...]

>         (method url-fetch)
> -       (uri (string-append "http://pagesperso-orange.fr/sebastien.godard/"
> -                           "sysstat-" version ".tar.xz"))
> +       (uri (string-append "https://github.com/sysstat/sysstat/archive/refs/tags/"
> +                           "v" version ".tar.gz"))

This is an autogenerated (“unstable”) tarball, as reported by ‘guix
lint’.  Could you change that to use ‘git-fetch’ instead?

TIA,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 56e5ad4530..3cc1c7fdac 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7495,14 +7495,14 @@  (define-public efibootmgr
 (define-public sysstat
   (package
     (name "sysstat")
-    (version "12.4.4")
+    (version "12.7.4")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://pagesperso-orange.fr/sebastien.godard/"
-                           "sysstat-" version ".tar.xz"))
+       (uri (string-append "https://github.com/sysstat/sysstat/archive/refs/tags/"
+                           "v" version ".tar.gz"))
        (sha256
-        (base32 "091xjip7l52dxal8dsfh5chksr4g9gclnssw3hjjxy84kr3yf4lm"))))
+        (base32 "0i4xs4638w280rx94ala42nlk8gzjh0ks9sdmdcb701fcixyj6vs"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no test suite.
@@ -7520,7 +7520,7 @@  (define-public sysstat
              (substitute* "Makefile"
                (("mkdir -p \\$\\(DESTDIR\\)\\$\\(SA_DIR\\)")
                 "")))))))
-    (home-page "http://sebastien.godard.pagesperso-orange.fr/")
+    (home-page "http://sysstat.github.io")
     (synopsis "Performance monitoring tools for Linux")
     (description "The sysstat utilities are a collection of performance
 monitoring tools for Linux.  These include @code{mpstat}, @code{iostat},