diff mbox series

[bug#67481] gnu: tractor: Change URI of source.

Message ID 20231127100109.93330-1-dani.behzi@ubuntu.com
State New
Headers show
Series [bug#67481] gnu: tractor: Change URI of source. | expand

Commit Message

Danial Behzadi Nov. 27, 2023, 10:01 a.m. UTC
---
 gnu/packages/tor.scm | 61 ++++++++++++++++++++++----------------------
 1 file changed, 30 insertions(+), 31 deletions(-)

Comments

Mathieu Othacehe Dec. 25, 2023, 5:32 p.m. UTC | #1
Hello Danial,

> -       (uri (pypi-uri "traxtor" version))
> +       (uri (string-append "https://framagit.org/tractor/tractor/-/archive/"
> +                           version "/tractor-" version ".tar.bz2"))

What's the rationale behind the URI change? It seems that pypi is still
providing traxtor.

> -    (native-inputs
> -     (list (list glib "bin")))       ; for glib-compile-schemas.
> -    (inputs
> -     (list python-fire
> -           python-psutil
> -           python-pygobject
> -           python-requests
> -           python-stem
> -           python-termcolor))
> +    (native-inputs (list (list glib "bin"))) ;for glib-compile-schemas.
> +    (inputs (list python-fire
> +                  python-psutil
> +                  python-pygobject
> +                  python-requests
> +                  python-stem
> +                  python-termcolor))

All the subsequent modifications should be made in another separate
commit. Could you please send an updated version?

Thanks,

Mathieu
Danial Behzadi Jan. 7, 2024, 1:24 p.m. UTC | #2
Close in favor of #68303
diff mbox series

Patch

diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index d4bf27a790..cb7fd571c5 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -441,41 +441,40 @@  (define-public tractor
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "traxtor" version))
+       (uri (string-append "https://framagit.org/tractor/tractor/-/archive/"
+                           version "/tractor-" version ".tar.bz2"))
        (sha256
-        (base32
-         "1542g6alycwlmvndxcijzn4d5lgycmxxb78gqd8qwgm9kw0fnr3q"))))
+        (base32 "0gnsgwgbipd1z3ra32mpglwy19jfay36y78nqg32zqka3lsha7rc"))))
     (build-system pyproject-build-system)
-    (native-inputs
-     (list (list glib "bin")))       ; for glib-compile-schemas.
-    (inputs
-     (list python-fire
-           python-psutil
-           python-pygobject
-           python-requests
-           python-stem
-           python-termcolor))
+    (native-inputs (list (list glib "bin"))) ;for glib-compile-schemas.
+    (inputs (list python-fire
+                  python-psutil
+                  python-pygobject
+                  python-requests
+                  python-stem
+                  python-termcolor))
     (arguments
      (list
-      #:tests? #f                   ; no test suite.
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-after 'install 'install-man-page
-            (lambda _
-              (let ((man1 (string-append #$output "/share/man/man1")))
-                (install-file "tractor/man/tractor.1" man1))))
-          (add-after 'install 'install-bash-completion
-            (lambda _
-              (mkdir "bash-completion")
-              (rename-file "tractor/tractor-completion"
-                           "bash-completion/tractor")
-              (let ((bash-completion
-                      (string-append #$output "/share/bash-completion/completions")))
-                (install-file "bash-completion/tractor" bash-completion))))
-          (add-after 'install 'install-gschema
-            (lambda _
-              (let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
-                (install-file "tractor/tractor.gschema.xml" schemas)))))))
+      #:tests? #f ;no test suite.
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'install 'install-man-page
+                     (lambda _
+                       (let ((man1 (string-append #$output "/share/man/man1")))
+                         (install-file "tractor/man/tractor.1" man1))))
+                   (add-after 'install 'install-bash-completion
+                     (lambda _
+                       (mkdir "bash-completion")
+                       (rename-file "tractor/tractor-completion"
+                                    "bash-completion/tractor")
+                       (let ((bash-completion (string-append #$output
+                                               "/share/bash-completion/completions")))
+                         (install-file "bash-completion/tractor"
+                                       bash-completion))))
+                   (add-after 'install 'install-gschema
+                     (lambda _
+                       (let ((schemas (string-append #$output
+                                       "/share/glib-2.0/schemas")))
+                         (install-file "tractor/tractor.gschema.xml" schemas)))))))
     (home-page "https://framagit.org/tractor")
     (synopsis "Setup an onion routing proxy")
     (description