diff mbox series

[bug#67476] gnu: kpackage: Work around flaky test.

Message ID 20231127041221.3665-1-hello@lnikki.la
State New
Headers show
Series [bug#67476] gnu: kpackage: Work around flaky test. | expand

Commit Message

Leo Nikkilä Nov. 27, 2023, 4:11 a.m. UTC
When parallel tests are enabled, plasma-querytest can fail with:

    5/11 Test  #5: plasma-querytest ....................Subprocess aborted***Exception:   0.02 sec
    ********* Start testing of QueryTest *********
    Config: Using QtTest library 5.15.10, Qt 5.15.10 (arm64-little_endian-lp64 shared (dynamic) release build; by GCC 11.3.0), unknown unknown
    PASS   : QueryTest::initTestCase()
    QFATAL : QueryTest::installAndQuery() QThread: Destroyed while thread is still running
    FAIL!  : QueryTest::installAndQuery() Received a fatal error.
    Loc: [Unknown file(0)]
    Totals: 1 passed, 1 failed, 0 skipped, 0 blacklisted, 3ms
    ********* Finished testing of QueryTest *********

I'm able to consistently reproduce this on an aarch64-linux machine.
`guix build --cores=1' can also work around this.

* gnu/packages/kde-frameworks.scm (kpackage): Work around flaky test.
[arguments]<#:parallel-tests?>: Disable.  Follows what Debian has done.
---
 gnu/packages/kde-frameworks.scm | 3 +++
 1 file changed, 3 insertions(+)


base-commit: 3778f778c37110460dd78088200cbd05eb0c49e4

Comments

Ludovic Courtès Dec. 3, 2023, 10:44 p.m. UTC | #1
Leo Nikkilä <hello@lnikki.la> skribis:

> When parallel tests are enabled, plasma-querytest can fail with:
>
>     5/11 Test  #5: plasma-querytest ....................Subprocess aborted***Exception:   0.02 sec
>     ********* Start testing of QueryTest *********
>     Config: Using QtTest library 5.15.10, Qt 5.15.10 (arm64-little_endian-lp64 shared (dynamic) release build; by GCC 11.3.0), unknown unknown
>     PASS   : QueryTest::initTestCase()
>     QFATAL : QueryTest::installAndQuery() QThread: Destroyed while thread is still running
>     FAIL!  : QueryTest::installAndQuery() Received a fatal error.
>     Loc: [Unknown file(0)]
>     Totals: 1 passed, 1 failed, 0 skipped, 0 blacklisted, 3ms
>     ********* Finished testing of QueryTest *********
>
> I'm able to consistently reproduce this on an aarch64-linux machine.
> `guix build --cores=1' can also work around this.
>
> * gnu/packages/kde-frameworks.scm (kpackage): Work around flaky test.
> [arguments]<#:parallel-tests?>: Disable.  Follows what Debian has done.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0384baae46..4572d55cb8 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2028,6 +2028,9 @@  (define-public kpackage
            qtbase-5))
     (arguments
      (list
+      ;; The `plasma-querytest' test is known to fail when tests are run in parallel:
+      ;; <https://sources.debian.org/src/kpackage/5.107.0-1/debian/changelog/#L92>
+      #:parallel-tests? #f
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'patch