diff mbox series

[bug#67026,2/3] gnu: java-openjfx-graphics: Make java-swt optional.

Message ID 20231109191309.6876-2-julien@lepiller.eu
State New
Headers show
Series [bug#67026,1/3] gnu: javacc: Do not reference a jdk. | expand

Commit Message

Julien Lepiller Nov. 9, 2023, 7:13 p.m. UTC
It is used for an optional part of openjfx and not used by current
packages in Guix. Swt has a reference to a library in the JDK and has a
huge closure size because of that.  This reduces closure by 1GB for this
package and dependents (including josm).

* gnu/packages/java.scm (java-openjfx-graphics)[native-inputs]: Move java-swt...
[inputs]: ...to here.

Change-Id: I7d8cb14569d5a9f451944695225a2dff143bf190
---
 gnu/packages/java.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index eded386a03..d73550c042 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2311,7 +2311,9 @@  (define-public java-openjfx-graphics
                                         (string-append target new-name))))
                          (find-files "netbeans" "\\.so$"))))))))
     (propagated-inputs
-     (list java-openjfx-base java-swt))
+     (list java-openjfx-base))
+    (inputs
+     (list java-swt))
     ;; XXX: for unknown reasons
     ;; modules/graphics/src/main/native-prism-sw/JNativeSurface.c is missing
     ;; in this revision.