diff mbox series

[bug#67016,1/7] gnu: linux-libre 6.5: Update to 6.5.11.

Message ID 20231109132909.18926-1-w@wmeyer.eu
State New
Headers show
Series linux-libre kernel updates (2023-11-09) | expand

Commit Message

Wilko Meyer Nov. 9, 2023, 1:28 p.m. UTC
* gnu/packages/linux.scm (linux-libre-6.5-version): Update to 6.5.11.
(linux-libre-6.5-pristine-source): Update hash.

Change-Id: I38642a1c34677dd1ee74c77411490408c7c843e6
---
 gnu/packages/linux.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Nov. 10, 2023, 6:36 p.m. UTC | #1
On Thu, Nov 09, 2023 at 02:28:42PM +0100, Wilko Meyer wrote:
> * gnu/packages/linux.scm (linux-libre-6.5-version): Update to 6.5.11.
> (linux-libre-6.5-pristine-source): Update hash.

Thanks!

Pushed to 'kernel-updates'
Leo Famulari Nov. 11, 2023, 7:32 a.m. UTC | #2
On Fri, Nov 10, 2023 at 01:36:02PM -0500, Leo Famulari wrote:
> Pushed to 'kernel-updates'

Some of the packages are failing to build because the deblob scripts
were changed upstream but not updated in the patches:

https://ci.guix.gnu.org/eval/909004

Some of the older kernel series were given a different download URL
structure from the otherwise normal schema, as part of issuing a new
variant of old releases.

The 'fetch-linux-libre-deblob' script takes an argument for the revision
'-r', used like '-r gnu1'. 

If you know the linux-libre version has been released but you get 404
for the deblob scripts, you'll know you need to pass '-r gnu1'.
Leo Famulari Nov. 14, 2023, 1 a.m. UTC | #3
On Sat, Nov 11, 2023 at 02:32:08AM -0500, Leo Famulari wrote:
> Some of the packages are failing to build because the deblob scripts
> were changed upstream but not updated in the patches:
> 
> https://ci.guix.gnu.org/eval/909004

I think the problem was only with the 4.19 series.

I amended the patches and sent a revised patch series, and I also pushed
again to 'kernel-updates'.
Leo Famulari Nov. 14, 2023, 5:11 a.m. UTC | #4
On Thu, Nov 09, 2023 at 02:28:42PM +0100, Wilko Meyer wrote:
> * gnu/packages/linux.scm (linux-libre-6.5-version): Update to 6.5.11.
> (linux-libre-6.5-pristine-source): Update hash.

Pushed as c9255451b549f2999b83aa344d2412802225adf8, thanks!
Leo Famulari Nov. 14, 2023, 5:14 a.m. UTC | #5
On Tue, Nov 14, 2023 at 12:11:52AM -0500, Leo Famulari wrote:
> On Thu, Nov 09, 2023 at 02:28:42PM +0100, Wilko Meyer wrote:
> > * gnu/packages/linux.scm (linux-libre-6.5-version): Update to 6.5.11.
> > (linux-libre-6.5-pristine-source): Update hash.
> 
> Pushed as c9255451b549f2999b83aa344d2412802225adf8, thanks!

I forgot to sign before attempting to push, and so this patch series was
actually pushed as 8074235a7e820ab6dd61179be3f73bf7ef85b1aa

Sorry for the confusion!
Wilko Meyer Nov. 15, 2023, 10:02 a.m. UTC | #6
Hi Leo,

Leo Famulari <leo@famulari.name> writes:
> I think the problem was only with the 4.19 series.
>
> I amended the patches and sent a revised patch series, and I also pushed
> again to 'kernel-updates'.

Thanks for reviewing & fixing the 4.19 patch! The 4.19 deblob scripts
must've slipped through while preparing the patch series (was fairly
certain I did check, but according to my shell history I seemingly
missed out on checking the deblob scripts for 4.19).
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 95a66e3d6a..aac88f123e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -493,7 +493,7 @@  (define (%upstream-linux-source version hash)
 ;; The current "stable" kernels. That is, the most recently released major
 ;; versions that are still supported upstream.
 
-(define-public linux-libre-6.5-version "6.5.10")
+(define-public linux-libre-6.5-version "6.5.11")
 (define-public linux-libre-6.5-gnu-revision "gnu")
 (define deblob-scripts-6.5
   (linux-libre-deblob-scripts
@@ -503,7 +503,7 @@  (define deblob-scripts-6.5
    (base32 "066z5lw5vrfayhv23hpfcm6fh6b7zmn2v13kfv1g3z3jl1wblhfh")))
 (define-public linux-libre-6.5-pristine-source
   (let ((version linux-libre-6.5-version)
-        (hash (base32 "12sswml8jvabv6bqx35lg3jj6gq8jjk365rghjngdy5d0j34jpx1")))
+        (hash (base32 "06dmb4hbwrms0lp4axphwgj8wbnzsym70sx55lxr501b53wlmqif")))
    (make-linux-libre-source version
                             (%upstream-linux-source version hash)
                             deblob-scripts-6.5)))