diff mbox series

[bug#66960] gnu: Add guile-algorithms

Message ID 20231105210747.117962-1-filip@lajszczak.dev
State New
Headers show
Series [bug#66960] gnu: Add guile-algorithms | expand

Commit Message

Filip Lajszczak Nov. 5, 2023, 9:07 p.m. UTC
Guile port of racket-algorithms

* gnu/packages/guile-xyz.scm (guile-algorithms): New variable.
---
 gnu/packages/guile-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Mathieu Othacehe Nov. 25, 2023, 6:17 p.m. UTC | #1
Hello,

> +          (sha256
> +            (base32
> +             "0sqnica53kpxc8lmsf9aqzf3wcfjnxq4sxg0j9ka4fjh0id931qc"))))

It looks like the hash is now:
0r4fgq0p8lwma4cmdjb1xy2r40wkb7rg5b0cri2cab698fmb97al.

Does it mean that the release package was updated?

> +     "Guile port of @url{https://docs.racket-lang.org/algorithms/index.html,
> +racket-algorithms}, a package containing many useful algorithms borrowed from many
> +other programming languages).")

You can remove both "many".

Thanks,

Mathieu
Filip Lajszczak Nov. 25, 2023, 7:09 p.m. UTC | #2
On 11/25/23 18:17, Mathieu Othacehe wrote:
> 
> Hello,
> 
>> +          (sha256
>> +            (base32
>> +             "0sqnica53kpxc8lmsf9aqzf3wcfjnxq4sxg0j9ka4fjh0id931qc"))))
> 
> It looks like the hash is now:
> 0r4fgq0p8lwma4cmdjb1xy2r40wkb7rg5b0cri2cab698fmb97al.
> 
> Does it mean that the release package was updated?

It should not have been as the tag was on the same commit, but it is now 
as I moved it to include small docs change. I do not totally understand.

> 
>> +     "Guile port of @url{https://docs.racket-lang.org/algorithms/index.html,
>> +racket-algorithms}, a package containing many useful algorithms borrowed from many
>> +other programming languages).")
> 
> You can remove both "many".
> 

Yep, make sense. It was just copied from the description of the original 
racket package, but it is better less bombastic.

> Thanks,
> 
> Mathieu

Thanks for your review. Amended patch to follow.

All the best,
Filip
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 8f4ada7800..c408cdb71b 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1373,6 +1373,31 @@  (define-public guile-aa-tree
 convenient nested tree operations.")
     (license license:gpl3+)))
 
+(define-public guile-algorithms
+  (package
+    (name "guile-algorithms")
+    (version "0.1")
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://git@git.sr.ht/~filiplajszczak/guile-algorithms")
+                 (commit (string-append "v" version))))
+          (file-name (git-file-name name version))
+          (sha256
+            (base32
+             "0sqnica53kpxc8lmsf9aqzf3wcfjnxq4sxg0j9ka4fjh0id931qc"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake pkg-config texinfo))
+    (inputs (list guile-3.0))
+    (synopsis "Guile port of racket-algorithms")
+    (description
+     "Guile port of @url{https://docs.racket-lang.org/algorithms/index.html,
+racket-algorithms}, a package containing many useful algorithms borrowed from many
+other programming languages).")
+    (home-page "https://guile-algorithms.lajszczak.dev/")
+    (license license:gpl3+)))
+
 (define-public guile-aws
   (let ((commit "f32bea12333e1054b97ab50e58a72636edabb5b7")
         (revision "1"))