diff mbox series

[bug#66584] gnu: add emacs-flexoki-themes

Message ID 20231017143729.168973-1-arnav.jose@gmail.com
State New
Headers show
Series [bug#66584] gnu: add emacs-flexoki-themes | expand

Commit Message

Andrew Jose Oct. 17, 2023, 2:37 p.m. UTC
This patch invalidates any previous patches sent on this issue.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Jan. 21, 2024, 11:27 p.m. UTC | #1
Hello,

Andrew Jose <arnav.jose@gmail.com> writes:

> +(define-public emacs-flexoki-themes
> +  (let ((commit "4285faa2f6fd95c46b42fa922e3309f6a0ad0711")
> +        (revision "0.12"))

Thank you. I applied your patch and bumped version to 0.20.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb8c25f9b5..e2a546d35d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2451,6 +2451,29 @@  (define-public emacs-dante
 supports type hints, definition-jumping, completion, and more.")
     (license license:gpl3+)))
 
+(define-public emacs-flexoki-themes
+  (let ((commit "4285faa2f6fd95c46b42fa922e3309f6a0ad0711")
+        (revision "0.12"))
+    (package
+      (name "emacs-flexoki-themes")
+      (version revision)
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/crmsnbleyd/flexoki-emacs-theme")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "18y63cz6brxynz5k7lq9j3jrvz90w6mjqnpaaj3yp7xmr19n7q0y"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/crmsnbleyd/flexoki-emacs-theme")
+      (synopsis "Inky colour scheme for prose and code")
+      (description
+       "Flexoki-themes is a pair of light and dark themes for GNU Emacs based on
+the Flexoki colour scheme by Steph Ango.")
+      (license license:gpl3+))))
+
 (define-public emacs-flycheck
   (package
     (name "emacs-flycheck")