diff mbox series

[bug#66584] gnu: add emacs-flexoki-themes

Message ID 20231017092206.164273-1-arnav.jose@gmail.com
State New
Headers show
Series [bug#66584] gnu: add emacs-flexoki-themes | expand

Commit Message

Andrew Jose Oct. 17, 2023, 9:22 a.m. UTC
imported from melpa

This patch reverts the previous one and also uses the latest ref from MELPA. It is tested to build and I apologise for the previous one, which was indeed wrong
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Oct. 17, 2023, 9:48 a.m. UTC | #1
Hello,

Andrew Jose <arnav.jose@gmail.com> writes:

> +(define-public emacs-flexoki-themes

Thanks.

> +  (let ((commit "4285faa2f6fd95c46b42fa922e3309f6a0ad0711")
> +        (revision "20231017.501"))
> +    (package
> +      (name "emacs-flexoki-themes")
> +      (version revision)


The version should be "0.12". Guix doesn't follow MELPA numbering, but
rather upstream versioning.

> +      (synopsis "An inky colour scheme for prose and code")

The synopsis shouldn't start out with an article, such as "An":

  "Inky colour scheme …"

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb8c25f9b5..b59a3f1321 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2451,6 +2451,29 @@  (define-public emacs-dante
 supports type hints, definition-jumping, completion, and more.")
     (license license:gpl3+)))
 
+(define-public emacs-flexoki-themes
+  (let ((commit "4285faa2f6fd95c46b42fa922e3309f6a0ad0711")
+        (revision "20231017.501"))
+    (package
+      (name "emacs-flexoki-themes")
+      (version revision)
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/crmsnbleyd/flexoki-emacs-theme")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "18y63cz6brxynz5k7lq9j3jrvz90w6mjqnpaaj3yp7xmr19n7q0y"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/crmsnbleyd/flexoki-emacs-theme")
+      (synopsis "An inky colour scheme for prose and code")
+      (description
+       "Flexoki-themes is a pair of light and dark themes for GNU Emacs based on
+the Flexoki colour scheme by Steph Ango.")
+      (license license:gpl3+))))
+
 (define-public emacs-flycheck
   (package
     (name "emacs-flycheck")