diff mbox series

[bug#66584] gnu: add emacs-flexoki-themes

Message ID 20231017053531.9124-1-arnav.jose@gmail.com
State New
Headers show
Series [bug#66584] gnu: add emacs-flexoki-themes | expand

Commit Message

Andrew Jose Oct. 17, 2023, 5:35 a.m. UTC
This commit adds the flexoki-themes package imported from MELPA
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Christopher Baines Oct. 17, 2023, 8:48 a.m. UTC | #1
Andrew Jose <arnav.jose@gmail.com> writes:

> This commit adds the flexoki-themes package imported from MELPA
> ---
>  gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index bb8c25f9b5..40773b13ff 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -2451,6 +2451,29 @@ (define-public emacs-dante
>  supports type hints, definition-jumping, completion, and more.")
>      (license license:gpl3+)))
>
> +(define-public emacs-flexoki-themes
> +(package
> +  ((name "emacs-flexoki-themes")
> +   (version "20231015.2014")

The bit above where you've got (package (( looks wrong, have you managed
to build this pacakge locally?
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb8c25f9b5..40773b13ff 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2451,6 +2451,29 @@  (define-public emacs-dante
 supports type hints, definition-jumping, completion, and more.")
     (license license:gpl3+)))
 
+(define-public emacs-flexoki-themes
+(package
+  ((name "emacs-flexoki-themes")
+   (version "20231015.2014")
+   (source
+    (origin
+      (method git-fetch)
+      (uri
+       (git-reference
+        (url
+         "https://github.com/crmsnbleyd/flexoki-emacs-theme.git")
+        (commit "4285faa2f6fd95c46b42fa922e3309f6a0ad0711")))
+      (sha256
+       (base32
+        "18y63cz6brxynz5k7lq9j3jrvz90w6mjqnpaaj3yp7xmr19n7q0y"))))
+   (build-system emacs-build-system)
+   (home-page "https://github.com/crmsnbleyd/flexoki-emacs-theme")
+   (synopsis "An inky colour scheme for prose and code")
+   (description
+    "Flexoki-themes is a pair of light and dark themes for GNU Emacs based on
+the Flexoki colour scheme by Steph Ango.")
+   (license licence:gpl3+))))
+
 (define-public emacs-flycheck
   (package
     (name "emacs-flycheck")