diff mbox series

[bug#66208] gnu: add python-shshsh

Message ID 20230926092932.5886-1-arnav.jose@gmail.com
State New
Headers show
Series [bug#66208] gnu: add python-shshsh | expand

Commit Message

Andrew Jose Sept. 26, 2023, 9:29 a.m. UTC
Adds a new module, shshsh, from github as the pypi version does not have
a license yet. Its homepage: https://github.com/zqqqqz2000/shshsh
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Marco Rimoldi March 20, 2024, 10:11 p.m. UTC | #1
I suggest using the package on Pypi: https://pypi.org/project/shshsh/1.0.6/

It's been updated since the initial patch.

Marco
Steve George April 4, 2024, 9:44 p.m. UTC | #2
Review:
  * submission: checked & updated commit format, synopsis and description
  * submission: checked license and patch applies cleanly
  * functionality: test installed and used in python
  * code: ran guix lint, formatting looked OK
  * added: Reviewed-by commit trailer
  * Re-roll to trigger QA build

Andrew Jose (1):
  gnu: Add python-shshsh.

 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 83b9867e007348693c9e5e2a567b688eb5b74964
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bebcfb50e9..bbfd4970c3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19072,6 +19072,31 @@  (define-public python-shellingham
 running in.")
     (license license:isc)))
 
+(define-public python-shshsh
+  (package
+   (name "python-shshsh")
+   (version "1.0.5")
+   (source
+    (origin
+     (method git-fetch)
+     (uri
+      (git-reference
+       (url "https://github.com/zqqqqz2000/shshsh")
+       (commit "d9b846782e4d5ae6d02aa3febffb11e746e34a80")))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32
+       "0l661h9nf1vlaw5242yiq0cxk44p76xl88xm4327qisf2k136m52"))))
+   (build-system pyproject-build-system)
+   (native-inputs
+    (list python-poetry-core
+	  python-pytest
+          python-tox))
+   (home-page "https://github.com/zqqqqz2000/shshsh")
+   (synopsis "bridge of python and shell")
+   (description "bridge of python and shell")
+   (license license:expat)))
+
 (define-public python-memcached
   (package
     (name "python-memcached")