diff mbox series

[bug#66103,v2] gnu: keepassxc: Switch to qt-build-system.

Message ID 20230923131622.22200-1-timotej.lazar@araneo.si
State New
Headers show
Series [bug#66103,v2] gnu: keepassxc: Switch to qt-build-system. | expand

Commit Message

Timotej Lazar Sept. 23, 2023, 1:14 p.m. UTC
* gnu/packages/password-utils.scm (keepassxc): Use qt-build-system.
[build-system]: Switch to qt-build-system.
[arguments]: Drop superfluous phase and modules.
[inputs]: Drop qtbase-5.
---
The package was updated on master, so I’m sending just the build-system
change. Workaround for the failing test is still necessary.

 gnu/packages/password-utils.scm | 14 +++-----------
 1 file changed, 3 insertions(+), 11 deletions(-)

Comments

Efraim Flashner Sept. 28, 2023, 4:36 p.m. UTC | #1
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index be85898c41..9e9e48c1f5 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -63,6 +63,7 @@  (define-module (gnu packages password-utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
   #:use-module (guix gexp)
@@ -154,14 +155,9 @@  (define-public keepassxc
                            version "-src.tar.xz"))
        (sha256
         (base32 "0w6nh2lnzfqcxasfsppmh4q309p1flzgfiv25hahzsd8kx879055"))))
-    (build-system cmake-build-system)
+    (build-system qt-build-system)
     (arguments
      (list
-      #:modules '((guix build cmake-build-system)
-                  (guix build qt-utils)
-                  (guix build utils))
-      #:imported-modules `(,@%cmake-build-system-modules
-                           (guix build qt-utils))
       #:configure-flags
       #~(append
           (list "-DWITH_XC_ALL=YES"
@@ -178,10 +174,7 @@  (define-public keepassxc
                 ;; Fails with "TestCli::testClip() Compared values are not the
                 ;; same".  That test also requires a phase with (setenv
                 ;; "QT_QPA_PLATFORM" "offscreen") in order to work.
-                (invoke "ctest" "--exclude-regex" "testcli"))))
-          (add-after 'install 'wrap-qt
-            (lambda* (#:key inputs #:allow-other-keys)
-              (wrap-qt-program "keepassxc" #:output #$output #:inputs inputs))))))
+                (invoke "ctest" "--exclude-regex" "testcli")))))))
     (native-inputs
      (append
        (list qttools-5)
@@ -201,7 +194,6 @@  (define-public keepassxc
            minizip
            pcsc-lite
            qrencode
-           qtbase-5
            qtsvg-5
            qtwayland-5
            qtx11extras