diff mbox series

[bug#66103] gnu: keepassxc: Update to 2.7.6.

Message ID 20230919144138.5269-1-timotej.lazar@araneo.si
State New
Headers show
Series [bug#66103] gnu: keepassxc: Update to 2.7.6. | expand

Commit Message

Timotej Lazar Sept. 19, 2023, 2:40 p.m. UTC
* gnu/packages/password-utils.scm (keepassxc): Update to 2.7.6.
[build-system]: Switch to qt-build-system.
[arguments]: Drop superfluous phase and modules.
[inputs]: Drop qtbase-5.
---
 gnu/packages/password-utils.scm | 18 +++++-------------
 1 file changed, 5 insertions(+), 13 deletions(-)

Comments

Bruno Victal Sept. 20, 2023, 5:26 p.m. UTC | #1
Hi Timotej,

Timotej Lazar <timotej.lazar@araneo.si> writes:
> @@ -178,10 +174,7 @@ (define-public keepassxc
>                  ;; Fails with "TestCli::testClip() Compared values are not the
>                  ;; same".  That test also requires a phase with (setenv
>                  ;; "QT_QPA_PLATFORM" "offscreen") in order to work.
> -                (invoke "ctest" "--exclude-regex" "testcli"))))
> -          (add-after 'install 'wrap-qt
> -            (lambda* (#:key inputs #:allow-other-keys)
> -              (wrap-qt-program "keepassxc" #:output #$output #:inputs inputs))))))
> +                (invoke "ctest" "--exclude-regex" "testcli")))))))

Can you confirm if this is still necessary?
I see that upstream has this commit [1] that suggests the issue has
already been fixed?


[1]: <https://github.com/keepassxreboot/keepassxc/commit/bb4f5c2e9427da591504cebeae8ecbb54c1da655>
Timotej Lazar Sept. 21, 2023, 6:41 a.m. UTC | #2
Bruno Victal <mirai@makinata.eu> [2023-09-20 18:26:42+0100]:
> Timotej Lazar <timotej.lazar@araneo.si> writes:
>> @@ -178,10 +174,7 @@ (define-public keepassxc
>>                  ;; Fails with "TestCli::testClip() Compared values are not the
>>                  ;; same".  That test also requires a phase with (setenv
>>                  ;; "QT_QPA_PLATFORM" "offscreen") in order to work.
>> -                (invoke "ctest" "--exclude-regex" "testcli"))))
>> -          (add-after 'install 'wrap-qt
>> -            (lambda* (#:key inputs #:allow-other-keys)
>> -              (wrap-qt-program "keepassxc" #:output #$output #:inputs inputs))))))
>> +                (invoke "ctest" "--exclude-regex" "testcli")))))))
>
> Can you confirm if this is still necessary?
> I see that upstream has this commit [1] that suggests the issue has
> already been fixed?

The test still fails. I tried setting QT_QPA_PLATFORM as mentioned in
the comment to no effect. The test also fails in a different way without
a writable HOME, but after setting it I got the message in the comment.

Thanks for the review!
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 753a29dcca..9e9e48c1f5 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -63,6 +63,7 @@  (define-module (gnu packages password-utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
   #:use-module (guix gexp)
@@ -145,7 +146,7 @@  (define-public pwgen
 (define-public keepassxc
   (package
     (name "keepassxc")
-    (version "2.7.5")
+    (version "2.7.6")
     (source
      (origin
        (method url-fetch)
@@ -153,15 +154,10 @@  (define-public keepassxc
                            "/releases/download/" version "/keepassxc-"
                            version "-src.tar.xz"))
        (sha256
-        (base32 "03002fncllr658mgl5s6an5wnh0a333qnkxad6aw85hqj004iqpd"))))
-    (build-system cmake-build-system)
+        (base32 "0w6nh2lnzfqcxasfsppmh4q309p1flzgfiv25hahzsd8kx879055"))))
+    (build-system qt-build-system)
     (arguments
      (list
-      #:modules '((guix build cmake-build-system)
-                  (guix build qt-utils)
-                  (guix build utils))
-      #:imported-modules `(,@%cmake-build-system-modules
-                           (guix build qt-utils))
       #:configure-flags
       #~(append
           (list "-DWITH_XC_ALL=YES"
@@ -178,10 +174,7 @@  (define-public keepassxc
                 ;; Fails with "TestCli::testClip() Compared values are not the
                 ;; same".  That test also requires a phase with (setenv
                 ;; "QT_QPA_PLATFORM" "offscreen") in order to work.
-                (invoke "ctest" "--exclude-regex" "testcli"))))
-          (add-after 'install 'wrap-qt
-            (lambda* (#:key inputs #:allow-other-keys)
-              (wrap-qt-program "keepassxc" #:output #$output #:inputs inputs))))))
+                (invoke "ctest" "--exclude-regex" "testcli")))))))
     (native-inputs
      (append
        (list qttools-5)
@@ -201,7 +194,6 @@  (define-public keepassxc
            minizip
            pcsc-lite
            qrencode
-           qtbase-5
            qtsvg-5
            qtwayland-5
            qtx11extras