diff mbox series

[bug#66064] gnu: python-plastid: Patch it for python 3.10.

Message ID 20230918033947.4556-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66064] gnu: python-plastid: Patch it for python 3.10. | expand

Commit Message

Mădălin Ionel Patrașcu Sept. 18, 2023, 3:39 a.m. UTC
* gnu/packages/bioinformatics.scm (python-plastid)[arguments]: Add
new phase patch-for-python-3.10.
---
 gnu/packages/bioinformatics.scm | 7 +++++++
 1 file changed, 7 insertions(+)


base-commit: 1d30ec935126f316187dfc26446347bc7de9868b

Comments

Ricardo Wurmus Sept. 18, 2023, 8:33 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/bioinformatics.scm (python-plastid)[arguments]: Add
> new phase patch-for-python-3.10.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c78f017a24..d7a9697c6e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3787,6 +3787,13 @@  (define-public python-plastid
                       "-xf" (assoc-ref inputs "test-data"))
               ;; This one requires bowtie-build
               (delete-file "plastid/test/functional/test_crossmap.py")))
+          (add-after 'unpack 'patch-for-python-3.10
+              (lambda _
+                ;; Some classes were moved from collections to collections.abc
+                ;; in Python 3.10.
+                (substitute* "plastid/readers/bigbed.pyx"
+                  ((", Iterable")
+                   "\nfrom collections.abc import Iterable"))))
           (add-before 'check 'build-extensions
             (lambda _
               ;; Cython extensions have to be built before running the tests.