diff mbox series

[bug#65934] gnu: Add smithforth.

Message ID 20230914052721.27820-1-elaexuotee@wilsonb.com
State New
Headers show
Series [bug#65934] gnu: Add smithforth. | expand

Commit Message

B. Wilson Sept. 14, 2023, 5:27 a.m. UTC
* gnu/packages/forth (smithforth): New variable.
---
 gnu/packages/forth.scm | 55 +++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 54 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Oct. 5, 2023, 12:46 p.m. UTC | #1
Hi,

"B. Wilson" <elaexuotee@wilsonb.com> skribis:

> * gnu/packages/forth (smithforth): New variable.

[…]

> +(define-public smithforth
> +  (package
> +    (name "smithforth")
> +    (version "220711")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append "https://dacvs.neocities.org/SF/SForth"
> +                            version "dmp.txt"))
> +        (sha256
> +          (base32 "0a39pv7529llsa3f48fmvwvlcp3f9v8qkn5ziw2l6kxf0qvli3lm"))))
> +    (build-system trivial-build-system)
> +    (inputs
> +     `(("system.fs"
> +        ,(origin
> +           (method url-fetch)
> +           (uri (string-append "https://dacvs.neocities.org/SF/system"
> +                               version "fs.txt"))
> +           (sha256
> +            (base32
> +             "17v1pp64s6n8q8w3kg48nd7zdcx2208y4svr5fpfms5lkyzg7z1m"))))))

Is this a binary VM image dump?

If so, is there source available, a way to bootstrap it?

> +    (native-inputs (list xxd))
> +    (arguments
> +     `(#:modules ((guix build utils))
> +       #:builder
> +       (begin
> +         (use-modules (guix build utils)
> +                      (ice-9 textual-ports))
> +         (let* ((sforth.dmp (assoc-ref %build-inputs "source"))
> +                (system.fs  (assoc-ref %build-inputs "system.fs"))

Please use a gexp here for #:builder and instead of the (assoc-ref …)
expressions above, use:

  #~(begin
      ;; …
      (let* ((sforth.dmp #$(package-source this-package))
             (system.fs #$(origin …)))
        …))

> +    (home-page "https://dacvs.neocities.org/SF/")
> +    (synopsis "Forth programming language for x86-64 desktop computers")

Please add a ‘supported-systems’ field so the package is clearly marked
as unsupported on architectures other than x86_64.

Thanks,
Ludo’.
B. Wilson Oct. 5, 2023, 2:35 p.m. UTC | #2
Thanks for taking a look.

> Is this a binary VM image dump?
> 
> If so, is there source available, a way to bootstrap it?

The binary is the source, per se. The author hand-wrote x86_64 opcodes in hex,
which is what dmp.txt contains. This is "compiled" by using xxd to write those
bytes out to a file. Then system.fs is just a blob of Forth source that gets
appended to the binary.

It's kind of magical that this scheme works at all, but that's Forth for ya.

> Please use a gexp here for #:builder and instead of the (assoc-ref …)
> expressions above, use:
> 
>   #~(begin
>       ;; …
>       (let* ((sforth.dmp #$(package-source this-package))
>              (system.fs #$(origin …)))
>         …))
> 
> > +    (home-page "https://dacvs.neocities.org/SF/")
> > +    (synopsis "Forth programming language for x86-64 desktop computers")

Ah, nice. Thanks. Will do.

> Please add a ‘supported-systems’ field so the package is clearly marked
> as unsupported on architectures other than x86_64.

Perfect. I didn't realize we had such a field. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/forth.scm b/gnu/packages/forth.scm
index 8cb6ac8391..9910243ac1 100644
--- a/gnu/packages/forth.scm
+++ b/gnu/packages/forth.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Nikita <nikita@n0.is>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2023 B. Wilson <elaexuotee@wilsonb.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,7 +23,9 @@  (define-module (gnu packages forth)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module (gnu packages m4))
+  #:use-module (guix build-system trivial)
+  #:use-module (gnu packages m4)
+  #:use-module (gnu packages vim))
 
 (define-public gforth
   (package
@@ -58,3 +61,53 @@  (define-public gforth
 included.")
     (home-page "https://www.gnu.org/software/gforth/")
     (license license:gpl3+)))
+
+(define-public smithforth
+  (package
+    (name "smithforth")
+    (version "220711")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://dacvs.neocities.org/SF/SForth"
+                            version "dmp.txt"))
+        (sha256
+          (base32 "0a39pv7529llsa3f48fmvwvlcp3f9v8qkn5ziw2l6kxf0qvli3lm"))))
+    (build-system trivial-build-system)
+    (inputs
+     `(("system.fs"
+        ,(origin
+           (method url-fetch)
+           (uri (string-append "https://dacvs.neocities.org/SF/system"
+                               version "fs.txt"))
+           (sha256
+            (base32
+             "17v1pp64s6n8q8w3kg48nd7zdcx2208y4svr5fpfms5lkyzg7z1m"))))))
+    (native-inputs (list xxd))
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils)
+                      (ice-9 textual-ports))
+         (let* ((sforth.dmp (assoc-ref %build-inputs "source"))
+                (system.fs  (assoc-ref %build-inputs "system.fs"))
+                (xxd        (string-append (assoc-ref %build-inputs "xxd")
+                                           "/bin/xxd"))
+                (bin        (string-append (assoc-ref %outputs "out") "/bin")))
+           (copy-file sforth.dmp "sforth.dmp")
+           (substitute* "sforth.dmp" (("#.*$") "\n"))
+           (with-output-to-file "sforth"
+             (lambda _
+               (invoke xxd "-p" "-r" "sforth.dmp")
+               (call-with-input-file system.fs
+                 (lambda (port) (display (get-string-all port)))))
+             #:binary #t)
+           (chmod "sforth" #o755)
+           (install-file "sforth" bin)))))
+    (home-page "https://dacvs.neocities.org/SF/")
+    (synopsis "Forth programming language for x86-64 desktop computers")
+    (description "SmithForth is an implementation of the Forth programming
+language for x86-64 desktop computers. SmithForth is a text interpreter that
+runs in a Linux text console.")
+    (license license:expat-0)))