diff mbox series

[bug#65916] gnu: python-hicmatrix: Fix "'build': uncaught exception".

Message ID 20230913133942.9140-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#65916] gnu: python-hicmatrix: Fix "'build': uncaught exception". | expand

Commit Message

Mădălin Ionel Patrașcu Sept. 13, 2023, 1:39 p.m. UTC
* gnu/packages/bioinformatics.scm (python-hicmatrix): Add new phase
'fix-references that remove the * character from the name of the
requirements.
---
 gnu/packages/bioinformatics.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)


base-commit: 9996896dc252a02ba3b17473a685ce8957237546

Comments

Ricardo Wurmus Sept. 13, 2023, 8:21 p.m. UTC | #1
Hi, thanks for the patch.

> * gnu/packages/bioinformatics.scm (python-hicmatrix): Add new phase
> 'fix-references that remove the * character from the name of the
> requirements.
> ---
>  gnu/packages/bioinformatics.scm | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
> index e24d70e569..06ff34e877 100644
> --- a/gnu/packages/bioinformatics.scm
> +++ b/gnu/packages/bioinformatics.scm
> @@ -16228,7 +16228,11 @@ (define-public python-hicmatrix
>      (arguments
>       (list
>        #:phases
> -      '(modify-phases %standard-phases
> +      #~(modify-phases %standard-phases
> +         (add-after 'unpack 'fix-references
> +           (lambda _
> +              (substitute* "setup.py"
> +                ((".\\*\"") ".0\""))))

I simplified this to remove the “.0”, renamed the phase because it isn’t
about fixing references, and removed the gexp.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e24d70e569..06ff34e877 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16228,7 +16228,11 @@  (define-public python-hicmatrix
     (arguments
      (list
       #:phases
-      '(modify-phases %standard-phases
+      #~(modify-phases %standard-phases
+         (add-after 'unpack 'fix-references
+           (lambda _
+              (substitute* "setup.py"
+                ((".\\*\"") ".0\""))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?