diff mbox series

[bug#65643,v2] gnu: Add emacs-flymake-guile.

Message ID 20230906004729.2588-1-distopico@riseup.net
State New
Headers show
Series [bug#65643,v2] gnu: Add emacs-flymake-guile. | expand

Commit Message

Distopico Sept. 6, 2023, 12:46 a.m. UTC
From v1 -> v2 remove flymake-quickdef dependency and update version.

* gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.
---

* gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.

 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Andrew Tropin Sept. 7, 2023, 12:31 p.m. UTC | #1
On 2023-09-05 19:46, Distopico wrote:

Hi Camilo!

> From v1 -> v2 remove flymake-quickdef dependency and update version.
>
> * gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.
> ---

Under --- is a better place for reroll notes, text here doesn't go to
commit message body.

>
> * gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.
>
>  gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 3eaf215134..463cae82fe 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -132,6 +132,7 @@
>  ;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
>  ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
>  ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
> +;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -2497,6 +2498,29 @@ (define-public emacs-flymake-collection
>  modes.")
>      (license license:expat)))
>  
> +(define-public emacs-flymake-guile
> +  (package
> +    (name "emacs-flymake-guile")
> +    (version "0.5")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url
> +              "https://framagit.org/flymake-backends/flymake-guile.git")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "0cb2wcn34bzj93y7s1g2b2sxv79vqihb3a5n0rhxbrddfila95hh"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://framagit.org/flymake-backends/flymake-guile")
> +    (synopsis "GNU Guile support for Flymake")
> +    (description
> +     "This package provides a Flymake backend for GNU Guile using @code{guild
> +compile}.")
> +    (license license:gpl3+)))
> +
>  (define-public emacs-flymake-popon
>    (package
>      (name "emacs-flymake-popon")

Thank you for the package, applied, merged, updated commit message,
pushed.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3eaf215134..463cae82fe 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -132,6 +132,7 @@ 
 ;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
 ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
 ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2497,6 +2498,29 @@  (define-public emacs-flymake-collection
 modes.")
     (license license:expat)))
 
+(define-public emacs-flymake-guile
+  (package
+    (name "emacs-flymake-guile")
+    (version "0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url
+              "https://framagit.org/flymake-backends/flymake-guile.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0cb2wcn34bzj93y7s1g2b2sxv79vqihb3a5n0rhxbrddfila95hh"))))
+    (build-system emacs-build-system)
+    (home-page "https://framagit.org/flymake-backends/flymake-guile")
+    (synopsis "GNU Guile support for Flymake")
+    (description
+     "This package provides a Flymake backend for GNU Guile using @code{guild
+compile}.")
+    (license license:gpl3+)))
+
 (define-public emacs-flymake-popon
   (package
     (name "emacs-flymake-popon")