diff mbox series

[bug#65658] gnu: Add fonts-tlwg.

Message ID 20230831065214.629-1-chris@bumblehead.com
State New
Headers show
Series [bug#65658] gnu: Add fonts-tlwg. | expand

Commit Message

chris Aug. 31, 2023, 6:52 a.m. UTC
* gnu/packages/fonts.scm (fonts-tlwg): New variable.
---
 gnu/packages/fonts.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: d6966b8a5b4f2ddda2bc685b9642e7a1c2cbe17c

Comments

Bruno Victal Aug. 31, 2023, 4:05 p.m. UTC | #1
Close, duplicate of #65657.

[1]: <https://issues.guix.gnu.org/65657>
Maxim Cournoyer Sept. 6, 2023, 12:53 a.m. UTC | #2
Hi!

chris <chris@bumblehead.com> writes:

> * gnu/packages/fonts.scm (fonts-tlwg): New variable.

Thank you for your contribution!

>  gnu/packages/fonts.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index e10227f020..78c0e0eb4c 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -57,6 +57,7 @@
>  ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
>  ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
>  ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
> +;;; Copyright © 2023 chris <chris@bumblehead.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -3390,3 +3391,25 @@ (define-public font-recursive
>  primarily to meet the needs of programming environments and application
>  interfaces.")
>      (license license:silofl1.1)))
> +
> +(define-public fonts-tlwg
> + (package
> +   (name "fonts-tlwg")
> +   (version "0.7.3")
> +   (source
> +    (origin
> +     (method url-fetch)
> +     (uri (string-append
> +           "https://github.com/tlwg/" name
> +           "/releases/download/v" version "/" name "-" version ".tar.xz"))
> +     (sha256
> +      (base32
> +       "00mv8rmjpsk8jbbl978q3yrc2pxj8a86a3d092563dlc9n8gykkf"))))
> +   (native-inputs (list fontforge))
> +   (build-system gnu-build-system)
> +   (home-page "https://github.com/tlwg/fonts-tlwg/")
> +   (synopsis "Collection of scalable Thai fonts")
> +   (description "Fonts-TLWG is a collection of Thai scalable fonts available under free
> +licenses.  Its goal is to provide fonts that conform to existing standards
> +and recommendations, so that it can be a reference implementation.")

We do not use 'free licenses' or 'open source' or similar terms to
describe packages in Guix, as that is implied by our FSDG promise.

> +   (license license:gpl2)))

This should be gpl2+, since the license text mentions (emphasis mine):

	This font is free software; you can redistribute it and/or modify it
	under the terms of the GNU General Public License as published by the
	Free Software Foundation; either version 2 of the License, *or (at your
	option) any later version*.

I've applied it with small changes for the above.

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e10227f020..78c0e0eb4c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -57,6 +57,7 @@ 
 ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
 ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 chris <chris@bumblehead.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3390,3 +3391,25 @@  (define-public font-recursive
 primarily to meet the needs of programming environments and application
 interfaces.")
     (license license:silofl1.1)))
+
+(define-public fonts-tlwg
+ (package
+   (name "fonts-tlwg")
+   (version "0.7.3")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "https://github.com/tlwg/" name
+           "/releases/download/v" version "/" name "-" version ".tar.xz"))
+     (sha256
+      (base32
+       "00mv8rmjpsk8jbbl978q3yrc2pxj8a86a3d092563dlc9n8gykkf"))))
+   (native-inputs (list fontforge))
+   (build-system gnu-build-system)
+   (home-page "https://github.com/tlwg/fonts-tlwg/")
+   (synopsis "Collection of scalable Thai fonts")
+   (description "Fonts-TLWG is a collection of Thai scalable fonts available under free
+licenses.  Its goal is to provide fonts that conform to existing standards
+and recommendations, so that it can be a reference implementation.")
+   (license license:gpl2)))