diff mbox series

[bug#65657] gnu: Add fonts-tlwg.

Message ID 20230830220642.24329-1-chris@bumblehead.com
State New
Headers show
Series [bug#65657] gnu: Add fonts-tlwg. | expand

Commit Message

chris Aug. 30, 2023, 10:06 p.m. UTC
* gnu/packages/fonts.scm (fonts-tlwg): New variable.
---
 gnu/packages/fonts.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

chris Aug. 31, 2023, 3:57 p.m. UTC | #1
closing as duplicate of 65658
chris Aug. 31, 2023, 4:23 p.m. UTC | #2
I sent an email to close this issue 65657 in favor of 65658, but the email did not appear on the issue page for 65657 and in the meantime someone else closed 65658 in favor of 65657. I hope the follow-up lint-updated patch sent here makes it through 65657 any advice is welcome, thank you.
chris Aug. 31, 2023, 4:30 p.m. UTC | #3
I sent an email to close this issue 65657 in favor of 65658, but the 
email did not appear on the issue page for 65657 and in the meantime 
someone else closed 65658 in favor of 65657. I hope this lint-updated 
patch makes it through 65657 any advice is welcome, thank you.
chris Sept. 1, 2023, 5:13 p.m. UTC | #4
This patch makes dedicated thai fonts available through guix. Locally, I have used this package for several months. Before the patch was applied, thai characters would render as little box characters. After the patch was applied, thai characters are rendered nicely.

The tlwg fonts are the primary thai fonts packaged by other distributions.
Maxim Cournoyer Sept. 6, 2023, 3:45 a.m. UTC | #5
Hi,

Christopher DePauw <chris@bumblehead.com> writes:

> I sent an email to close this issue 65657 in favor of 65658, but the
> email did not appear on the issue page for 65657 and in the meantime
> someone else closed 65658 in favor of 65657. I hope this lint-updated
> patch makes it through 65657 any advice is welcome, thank you.

I've applied 65658.  Closing!
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e10227f020..19bd8540af 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -57,6 +57,7 @@ 
 ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
 ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 chris <chris@bumblehead.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3390,3 +3391,26 @@  (define-public font-recursive
 primarily to meet the needs of programming environments and application
 interfaces.")
     (license license:silofl1.1)))
+
+(define-public fonts-tlwg
+ (package
+   (name "fonts-tlwg")
+   (version "0.7.3")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "https://github.com/tlwg/" name
+           "/releases/download/v" version "/" name "-" version ".tar.xz"))
+     (sha256
+      (base32
+       "00mv8rmjpsk8jbbl978q3yrc2pxj8a86a3d092563dlc9n8gykkf"))))
+   (native-inputs (list fontforge))
+   (build-system gnu-build-system)
+   ;; (build-system font-build-system)
+   (home-page "https://github.com/tlwg/fonts-tlwg/")
+   (synopsis "Collection of scalable Thai fonts")
+   (description "Fonts-TLWG is a collection of Thai scalable fonts available under free
+licenses.  Its goal is to provide fonts that conform to existing standards
+and recommendations, so that it can be a reference implementation.")
+   (license license:gpl2)))