diff mbox series

[bug#65636] gnu: git: Update to 2.42.0.

Message ID 20230830190430.61459-1-code@greghogan.com
State New
Headers show
Series [bug#65636] gnu: git: Update to 2.42.0. | expand

Commit Message

Greg Hogan Aug. 30, 2023, 7:03 p.m. UTC
* gnu/packages/version-control.scm (git): Update to 2.42.0.
---
 gnu/packages/version-control.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Simon Tournier Sept. 22, 2023, 8:14 a.m. UTC | #1
Hi,

On Wed, 30 Aug 2023 at 19:03, Greg Hogan <code@greghogan.com> wrote:
> * gnu/packages/version-control.scm (git): Update to 2.42.0.
> ---
>  gnu/packages/version-control.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

This change implies a lot of rebuilds – more than the QA threshold.

So I have applied and rebuilt all the packages (for x86_64 only, which
is already something for my resources :-)) listed by “guix refresh -l
git git-minimal”.  This update breaks these 9 packages:

        conan
        nototools
        python-bash-kernel
        python-clinguin
        python-h3
        python-jwst
        python-keras
        python-poliastro
        python-telingo

Could you give a look?

Well, considering the current model for merging, this change could
directly go to master (and avoid a core-updates cycle) since CI should
be able to handle the ~800 rebuilds.  However, I would prefer to avoid
the introduction of breakages. :-)

Cheers,
simon
Greg Hogan Oct. 17, 2023, 10:31 p.m. UTC | #2
On Fri, Sep 22, 2023 at 4:15 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
>
> Hi,
>
> On Wed, 30 Aug 2023 at 19:03, Greg Hogan <code@greghogan.com> wrote:
> > * gnu/packages/version-control.scm (git): Update to 2.42.0.
> > ---
> >  gnu/packages/version-control.scm | 6 +++---
> >  1 file changed, 3 insertions(+), 3 deletions(-)
>
> This change implies a lot of rebuilds – more than the QA threshold.
>
> So I have applied and rebuilt all the packages (for x86_64 only, which
> is already something for my resources :-)) listed by “guix refresh -l
> git git-minimal”.  This update breaks these 9 packages:
>
>         conan
>         nototools
>         python-bash-kernel
>         python-clinguin
>         python-h3
>         python-jwst
>         python-keras
>         python-poliastro
>         python-telingo
>
> Could you give a look?

python-jwst and python-poliastro fail to build for me on master
(c96ea941) due to test failures with floating point precision.

The remaining packages build successfully against this git 2.42 patch:
$ ./pre-inst-env guix build conan nototools python-bash-kernel
python-clinguin python-h3 python-keras python-telingo
/gnu/store/5lpypnafi7akb9yya82l29x4zrkgsw1v-python-telingo-2.1.1
/gnu/store/d7hmxpipghw74v4bdk3gy1xq0k789a8q-python-keras-2.3.1
/gnu/store/rq51438czgcab9d9vp0wl09k4myvbkj8-python-h3-4.0.0b2
/gnu/store/smrfjip766ifrcf3pzsfbjzp4hdsabd1-python-clinguin-1.0.0-beta
/gnu/store/z0fzl2g7pdp94hdpq5llmjlq20v5wfl2-python-bash-kernel-0.7.2
/gnu/store/8xymw6wdw782z35djznx8ssqszfb4lff-nototools-0.2.16
/gnu/store/n8v7xm47cawirwdmll79ismdzlwja54w-conan-2.0.9

> Well, considering the current model for merging, this change could
> directly go to master (and avoid a core-updates cycle) since CI should
> be able to handle the ~800 rebuilds.  However, I would prefer to avoid
> the introduction of breakages. :-)
>
> Cheers,
> simon
Greg Hogan Nov. 21, 2023, 1:14 p.m. UTC | #3
Closing due to the release of v2.43.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 699a091642..94f2076451 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -230,14 +230,14 @@  (define git-cross-configure-flags
 (define-public git
   (package
    (name "git")
-   (version "2.41.0")
+   (version "2.42.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://kernel.org/software/scm/git/git-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "0h40arw08xbpi2cbf7pvc947v963rjxz3inb2ar81zjc8byvlj77"))))
+              "039vr63xi55admhdn30pabpl1fd8kvfksznxhj24p6fjkw722y1j"))))
    (build-system gnu-build-system)
    (native-inputs
     `(("native-perl" ,perl)
@@ -257,7 +257,7 @@  (define-public git
                 version ".tar.xz"))
           (sha256
            (base32
-            "0xsqakgy0s60zpa13ilj6zj420kdh8pf4v3nrp1nziwj8ja4qymw"))))
+            "1fbkwpqkmmr32n4mraf8slmna3mmz2d63rhr06qk3bbpl1hdrq03"))))
       ;; For subtree documentation.
       ("asciidoc" ,asciidoc)
       ("docbook2x" ,docbook2x)