diff mbox series

[bug#65532] gnu: syncthing: Update to 1.23.7.

Message ID 20230825123144.2658-1-timotej.lazar@araneo.si
State New
Headers show
Series [bug#65532] gnu: syncthing: Update to 1.23.7. | expand

Commit Message

Timotej Lazar Aug. 25, 2023, 12:31 p.m. UTC
The uraggregate binary was merged into ursrv, so don’t attempt to install it.

* gnu/packages/syncthing.scm (syncthing): Update to 1.23.7.
[arguments]: Build with go-1.20.
---
 gnu/packages/syncthing.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès Sept. 14, 2023, 2:17 p.m. UTC | #1
Hi,

Timotej Lazar <timotej.lazar@araneo.si> skribis:

> The uraggregate binary was merged into ursrv, so don’t attempt to install it.
>
> * gnu/packages/syncthing.scm (syncthing): Update to 1.23.7.
> [arguments]: Build with go-1.20.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 414395251b..fd30360006 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -46,7 +46,7 @@  (define-module (gnu packages syncthing)
 (define-public syncthing
   (package
     (name "syncthing")
-    (version "1.23.6")
+    (version "1.23.7")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/syncthing/syncthing"
@@ -54,7 +54,7 @@  (define-public syncthing
                                   "/syncthing-source-v" version ".tar.gz"))
               (sha256
                (base32
-                "03myinspq61aiis29mq0xjigj5rh5jd8m0d9xakf43vi7pqgwjbc"))))
+                "1891dqcsg5r034bw19qjm6qg0zi1g0djcllp2c550zq7v1sdvn0q"))))
     (build-system go-build-system)
     ;; The primary Syncthing executable goes to "out", while the auxiliary
     ;; server programs and utility tools go to "utils".  This reduces the size
@@ -64,7 +64,7 @@  (define-public syncthing
      (list #:modules '((srfi srfi-26) ; for cut
                        (guix build utils)
                        (guix build go-build-system))
-           #:go go-1.19
+           #:go go-1.20
            #:import-path "github.com/syncthing/syncthing"
            ;; We don't need to install the source code for end-user applications.
            #:install-source? #f
@@ -101,7 +101,7 @@  (define-public syncthing
                                "stdisco" "stdiscosrv" "stevents" "stfileinfo"
                                "stfinddevice" "stfindignored" "stgenfiles"
                                "strelaypoolsrv" "strelaysrv" "stsigtool"
-                               "stvanity" "stwatchfile" "uraggregate" "ursrv")))))
+                               "stvanity" "stwatchfile" "ursrv")))))
 
          (add-after 'install 'install-docs
            (lambda _