diff mbox series

[bug#65289] gnu: Add emacs-yeetube

Message ID 20230814093819.69715-1-public@thanosapollo.com
State New
Headers show
Series [bug#65289] gnu: Add emacs-yeetube | expand

Commit Message

Thanos Apollo Aug. 14, 2023, 9:38 a.m. UTC
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Ludovic Courtès Sept. 11, 2023, 9:26 p.m. UTC | #1
Hi Thanos,

Thanos Apollo <public@thanosapollo.com> skribis:

> ---
>  gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)

I added a commit log that follows our conventions¹ and applied it.

Thank you!

Ludo’.

¹ https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f0751e39a..b9d1a5212c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -132,6 +132,7 @@ 
 ;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
 ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
 ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
+;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27683,6 +27684,33 @@  (define-public emacs-ytel-show
 and comments.")
       (license license:gpl3+))))
 
+(define-public emacs-yeetube
+  (package
+   (name "emacs-yeetube")
+   (version "1.4.2")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://git.sr.ht/~thanosapollo/yeetube.el")
+           (commit version)))
+     (sha256
+      (base32
+       "0vfap6sri6qnswrjsp6qvmrp98bvrfh58gwdqbjiakq1fzvcrm03"))
+     (file-name (git-file-name name version))))
+   (build-system emacs-build-system)
+   (inputs
+    (list mpv yt-dlp))
+   (home-page "https://sr.ht/~thanosapollo/yeetube.el")
+   (synopsis "Youtube & Invidious front-end for Emacs")
+   (description
+    "This package offers an Emacs interface that allows you to search YouTube
+or an Invidious instance for a specific query.  The search results are shown as
+links in an org-mode buffer.  The videos can be opened to a user-defined video
+player(by default mpv) or downloaded using yt-dlp.  This package also includes
+a yt-dlp front-end.")
+   (license license:gpl3+)))
+
 (define-public emacs-org-web-tools
   (package
     (name "emacs-org-web-tools")