diff mbox series

[bug#65278] gnu: webrtc-for-telegram-desktop: Update to commit 77c2121f7e6b8e694d6e908bbbe9be24214097da.

Message ID 20230814015327.30555-1-i@dan.games
State New
Headers show
Series [bug#65278] gnu: webrtc-for-telegram-desktop: Update to commit 77c2121f7e6b8e694d6e908bbbe9be24214097da. | expand

Commit Message

dan Aug. 14, 2023, 1:53 a.m. UTC
This patch update webrtc-for-telegram-desktop, trying to fix an issue causing
the voice call functionality malfunctioning.

* gnu/packages/telegram.scm (libyuv-for-telegram-desktop): Update to commit
77c2121f7e6b8e694d6e908bbbe9be24214097da.
* gnu/packages/telegram.scm (libsrtp-for-telegram-desktop): New variable.
* gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to
commit a45d8b8f0a99bd0e5118dda1dc4a8b7b3ad5dcfd.
[origin]: keep libsrtp_config instead of libsrtp.
[arguments]<#:phases>: copy libsrtp-for-telegram-desktop to src/third_party/libsrtp.
---
 gnu/packages/telegram.scm | 33 ++++++++++++++++++++++++---------
 1 file changed, 24 insertions(+), 9 deletions(-)


base-commit: e7b8edc74490ebd345ca3b518418a59d1d00abe2

Comments

dan Aug. 14, 2023, 3:02 a.m. UTC | #1
close 65278
duplication of 64748
dan Aug. 14, 2023, 3:07 a.m. UTC | #2
close 65278
duplication of 64748
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index aa5c303603..d95c97d375 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
 ;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
+;;; Copyright © 2023 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -83,8 +84,8 @@  (define-module (gnu packages telegram)
 (define %telegram-version "4.8.1")
 
 (define libyuv-for-telegram-desktop
-  (let ((commit "00950840d1c9bcbb3eb6ebc5aac5793e71166c8b")
-        (revision "2212"))
+  (let ((commit "77c2121f7e6b8e694d6e908bbbe9be24214097da")
+        (revision "2439"))
     (origin
       (method git-fetch)
       (uri (git-reference
@@ -95,7 +96,18 @@  (define libyuv-for-telegram-desktop
                   (git-version "0" revision commit)))
       (sha256
        (base32
-        "0mm56p8iapfild2xdw4w8zi35c3xm06fgagiali644gnxdmnym6c")))))
+        "1b4k8yskr9ffl5k8s9i0af1gn1pavsfixla26vh8bij69rdr7f9c")))))
+
+(define libsrtp-for-telegram-desktop
+  (origin
+    (method git-fetch)
+    (uri (git-reference
+          (url "https://github.com/cisco/libsrtp")
+          (commit (string-append "v" "2.5.0"))))
+    (file-name (git-file-name "libsrtp" "2.5.0"))
+    (sha256
+     (base32
+      "1ichw2v9s2mggi5p2wbbmlg55q4r48dxi3ks7ykfcfkmh7pb1w1s"))))
 
 (define cmake-helpers-for-telegram-desktop
   (origin
@@ -266,8 +278,8 @@  (define tgcalls-for-telegram-desktop
       "193m2gkvipijqbfd6a8mhg9nd63wlnshzgspk3pip57vk21l709z"))))
 
 (define-public webrtc-for-telegram-desktop
-  (let ((commit "5098730b9eb6173f0b52068fe2555b7c1015123a")
-        (revision "328"))
+  (let ((commit "a45d8b8f0a99bd0e5118dda1dc4a8b7b3ad5dcfd")
+        (revision "388"))
     (hidden-package
      (package
        (name "webrtc-for-telegram-desktop")
@@ -283,14 +295,14 @@  (define-public webrtc-for-telegram-desktop
           (file-name
            (git-file-name name version))
           (sha256
-           (base32 "1lk54zlrff59rj5k9dylsgz4sdds4728psrk8m3v9qn5y8d6z8qy"))
+           (base32 "1qs3ikkd6l56brj40cv6wlhx5gj5avisj9mj8ypjfwcyw9hb2n5y"))
           (modules '((guix build utils)
                      (ice-9 ftw)
                      (srfi srfi-1)))
           (snippet
            #~(begin
                (let ((keep
-                      '("libsrtp" "rnnoise"
+                      '("libsrtp_config" "rnnoise"
                         ;; Not available in Guix.
                         "pffft")))
                  (with-directory-excursion "src/third_party"
@@ -312,9 +324,12 @@  (define-public webrtc-for-telegram-desktop
              (add-after 'unpack 'unpack-additional-sources
                (lambda _
                  (let* ((third-party (string-append (getcwd) "/src/third_party"))
-                        (libyuv-to (string-append third-party "/libyuv")))
+                        (libyuv-to (string-append third-party "/libyuv"))
+                        (libsrtp-to (string-append third-party "/libsrtp")))
                    (copy-recursively #$libyuv-for-telegram-desktop
-                                     libyuv-to)))))))
+                                     libyuv-to)
+                   (copy-recursively #$libsrtp-for-telegram-desktop
+                                     libsrtp-to)))))))
        (native-inputs (list pkg-config python-wrapper yasm))
        (inputs
         (list abseil-cpp-cxxstd17