diff mbox series

[bug#65153] gnu: sdl2: Add vulkan-loader to rpath.

Message ID 20230808174958.16235-1-i@dan.games
State New
Headers show
Series [bug#65153] gnu: sdl2: Add vulkan-loader to rpath. | expand

Commit Message

dan Aug. 8, 2023, 5:49 p.m. UTC
* gnu/packages/sdl.scm (sdl2)
  [arguments]: Append the path to libvulkan.so to rpath.
  [inputs]: Add vulkan-loader.
---
 gnu/packages/sdl.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)


base-commit: 4547bc6fa3142dca77f7fc912368aeff31bd6e53

Comments

John Kehayias Nov. 28, 2023, 5:49 a.m. UTC | #1
On Wed, Aug 09, 2023 at 01:49 AM, dan wrote:

> * gnu/packages/sdl.scm (sdl2)
>   [arguments]: Append the path to libvulkan.so to rpath.
>   [inputs]: Add vulkan-loader.
> ---
>  gnu/packages/sdl.scm | 14 ++++++++++----
>  1 file changed, 10 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
> index 86ec1c033b..bb9fb19f9e 100644
> --- a/gnu/packages/sdl.scm
> +++ b/gnu/packages/sdl.scm
> @@ -14,6 +14,7 @@
>  ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
>  ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
>  ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> +;;; Copyright © 2023 dan <i@dan.games>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -59,6 +60,7 @@ (define-module (gnu packages sdl)
>    #:use-module (gnu packages pkg-config)
>    #:use-module (gnu packages pulseaudio)
>    #:use-module (gnu packages gl)
> +  #:use-module (gnu packages vulkan)
>    #:use-module (gnu packages xdisorg)
>    #:use-module (gnu packages xiph)
>    #:use-module (gnu packages xorg)
> @@ -132,11 +134,13 @@ (define-public sdl2
>                    #$flags))
>         ((#:make-flags flags ''())
>          #~(cons*
> -           ;; SDL dlopens libudev, so make sure it is in rpath. This overrides
> -           ;; the LDFLAG set in sdl’s configure-flags, which isn’t necessary
> -           ;; as sdl2 includes Mesa by default.
> +           ;; SDL dlopens libudev and libvulkan, so make sure they are in
> +           ;; rpath. This overrides the LDFLAG set in sdl’s configure-flags,
> +           ;; which isn’t necessary as sdl2 includes Mesa by default.
>             (string-append "LDFLAGS=-Wl,-rpath,"
> -                          #$(this-package-input "eudev") "/lib")
> +                          #$(this-package-input "eudev") "/lib"
> +                          ",-rpath,"
> +                          #$(this-package-input "vulkan-loader") "/lib")
>             #$flags))))
>      (inputs
>       ;; SDL2 needs to be built with ibus support otherwise some systems
> @@ -151,6 +155,7 @@ (define-public sdl2
>                 ibus-minimal
>                 libxkbcommon
>                 libxcursor               ;enables X11 cursor support
> +               vulkan-loader
>                 wayland
>                 wayland-protocols)))
>      (license license:bsd-3)))
> @@ -681,3 +686,4 @@ (define-public guile2.2-sdl2
>
>  (define-public guile3.0-sdl2
>    (deprecated-package "guile3.0-sdl2" guile-sdl2))
> +sdl2
>
> base-commit: 4547bc6fa3142dca77f7fc912368aeff31bd6e53

Pushed as 50521348c89140705ca157a7d77f4acda24c26c7 thanks!
diff mbox series

Patch

diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 86ec1c033b..bb9fb19f9e 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -59,6 +60,7 @@  (define-module (gnu packages sdl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages gl)
+  #:use-module (gnu packages vulkan)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xorg)
@@ -132,11 +134,13 @@  (define-public sdl2
                   #$flags))
        ((#:make-flags flags ''())
         #~(cons*
-           ;; SDL dlopens libudev, so make sure it is in rpath. This overrides
-           ;; the LDFLAG set in sdl’s configure-flags, which isn’t necessary
-           ;; as sdl2 includes Mesa by default.
+           ;; SDL dlopens libudev and libvulkan, so make sure they are in
+           ;; rpath. This overrides the LDFLAG set in sdl’s configure-flags,
+           ;; which isn’t necessary as sdl2 includes Mesa by default.
            (string-append "LDFLAGS=-Wl,-rpath,"
-                          #$(this-package-input "eudev") "/lib")
+                          #$(this-package-input "eudev") "/lib"
+                          ",-rpath,"
+                          #$(this-package-input "vulkan-loader") "/lib")
            #$flags))))
     (inputs
      ;; SDL2 needs to be built with ibus support otherwise some systems
@@ -151,6 +155,7 @@  (define-public sdl2
                ibus-minimal
                libxkbcommon
                libxcursor               ;enables X11 cursor support
+               vulkan-loader
                wayland
                wayland-protocols)))
     (license license:bsd-3)))
@@ -681,3 +686,4 @@  (define-public guile2.2-sdl2
 
 (define-public guile3.0-sdl2
   (deprecated-package "guile3.0-sdl2" guile-sdl2))
+sdl2