diff mbox series

[bug#65114,3/6] gnu: python-parsel: Update to 1.8.1.

Message ID 20230806153317.285639-3-monego@posteo.net
State New
Headers show
Series Update Scrapy. | expand

Commit Message

Vinicius Monego Aug. 6, 2023, 3:33 p.m. UTC
* gnu/packages/python-web.scm (python-parsel): Update to 1.8.1.
[build-system]: Use pyproject-build-system.
[propagated-inputs]: Add python-jmespath, python-typing-extensions.  Remove
python-six.
[native-inputs]: Add python-psutil.  Remove python-pytest-runner.
---
 gnu/packages/python-web.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9ecd9f35a3..70a1ab082f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8039,21 +8039,22 @@  (define-public python-protego
 (define-public python-parsel
   (package
     (name "python-parsel")
-    (version "1.6.0")
+    (version "1.8.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "parsel" version))
         (sha256
-          (base32 "0yawf9r3r863lwxj0n89i7h3n8xjbsl5b7n6xg76r68scl5yzvvh"))))
-    (build-system python-build-system)
+          (base32 "0f8yh30y3961a7kqwcnp4j3s7044ilakykiavc0skwdkr5l8xwmg"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
       (list python-cssselect
+            python-jmespath
             python-lxml
-            python-six
+            python-typing-extensions
             python-w3lib))
     (native-inputs
-      (list python-pytest python-pytest-runner))
+      (list python-psutil python-pytest))
     (home-page "https://github.com/scrapy/parsel")
     (synopsis "Extract data from HTML and XML using XPath and CSS selectors")
     (description "Parsel is a library to extract and remove data from