diff mbox series

[bug#65100] gnu: Add libmodbus.

Message ID 20230805161921.10571-1-monego@posteo.net
State New
Headers show
Series [bug#65100] gnu: Add libmodbus. | expand

Commit Message

Vinicius Monego Aug. 5, 2023, 4:19 p.m. UTC
* gnu/packages/engineering.scm (libmodbus): New variable.
---
 gnu/packages/engineering.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Maxim Cournoyer Sept. 6, 2023, 12:51 a.m. UTC | #1
Hi,

Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/engineering.scm (libmodbus): New variable.

Installed, thanks for contributing!
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index b5b4ad1b10..87e0b0e396 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1518,6 +1518,27 @@  (define-public sterm
     (home-page "https://github.com/wentasah/sterm")
     (license license:gpl3+)))
 
+(define-public libmodbus
+  (package
+    (name "libmodbus")
+    (version "3.1.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/stephane/libmodbus")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0nbpk1n56kclab8fl32dxi46v2bwax3gfk1zkc796srm7vj42sbv"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool))
+    (synopsis "Library for the Modbus protocol")
+    (description "@code{libmodbus} is a library to send/receive data with a
+device which respects the Modbus protocol.  This library can use a serial port
+or an Ethernet connection.")
+    (home-page "https://libmodbus.org/")
+    (license license:lgpl2.1+)))
 (define-public harminv
   (package
     (name "harminv")