diff mbox series

[bug#65099] gnu: Add libmseed.

Message ID 20230805161837.10391-1-monego@posteo.net
State New
Headers show
Series [bug#65099] gnu: Add libmseed. | expand

Commit Message

Vinicius Monego Aug. 5, 2023, 4:18 p.m. UTC
* gnu/packages/geo.scm (libmseed): New variable.
---
 gnu/packages/geo.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Mathieu Othacehe Oct. 14, 2023, 8:29 a.m. UTC | #1
Hey,

> +(define-public libmseed

https://qa.guix.gnu.org/issue/65099 reports that this package is not
building on armhf-linux and i686-linux. Do you think it could be easily
fixed?

Thanks,

Mathieu
Vinicius Monego April 7, 2024, 7:51 p.m. UTC | #2
Em sáb, 2023-10-14 às 10:29 +0200, Mathieu Othacehe escreveu:
> 
> Hey,
> 
> > +(define-public libmseed
> 
> https://qa.guix.gnu.org/issue/65099 reports that this package is not
> building on armhf-linux and i686-linux. Do you think it could be
> easily
> fixed?
> 
> Thanks,
> 
> Mathieu
> 

Hello,

I pushed the patch with a version update. Unfortunately, I don't know
how to fix the build on other ISAs, or if version 3+ even supports 32
bit ones.

Vinicius
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index cce4f2518d..a581495784 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1779,6 +1779,34 @@  (define-public libspatialindex
 ")
     (license license:expat)))
 
+(define-public libmseed
+  (package
+    (name "libmseed")
+    (version "3.0.17")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/EarthScope/libmseed")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "090xqcm9485vy6fbs2d1nd56fyy6mwh9kfflmflqqf4ckvaiskp6"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                                (string-append "PREFIX=" #$output))
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure))))
+    (home-page "https://earthscope.github.io/libmseed/")
+    (synopsis "Library for the miniSEED data format")
+    (description "The miniSEED library provides a framework for manipulation
+of SEED data records, a format for commonly used for seismological time
+series and related data.  The library includes the functionality to read
+and write data records, in addition to reconstructing time series
+from multiple records.")
+    (license license:asl2.0)))
+
 (define-public python-rtree
   (package
     (name "python-rtree")