diff mbox series

[bug#64748] gnu: webrtc-for-telegram-desktop: Update to a45d8b8

Message ID 20230805030015.28796-1-distopico@riseup.net
State New
Headers show
Series [bug#64748] gnu: webrtc-for-telegram-desktop: Update to a45d8b8 | expand

Commit Message

Distopico Aug. 5, 2023, 2:59 a.m. UTC
* gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to a45d8b8 revision commit

Fixes `telegram-desktop` calls that are not working with OpenSSL 3.
Now, `webrtc-for-telegram-desktop` uses sources from the Guix `libsrtp`
package instead of the submodule in the `unpack-additional-sources` phase.

see: https://github.com/telegramdesktop/tdesktop/issues/26108

---
* gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to a45d8b8 revision commit

Fixes `telegram-desktop` calls that are not working with OpenSSL 3.
Now, `webrtc-for-telegram-desktop` uses sources from the Guix `libsrtp`
package instead of the submodule in the `unpack-additional-sources` phase.

 gnu/packages/telegram.scm | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)


base-commit: cf9904bcc8dd03e73675475bb4d8746dc434e415

Comments

Hilton Chain Aug. 7, 2023, 9:38 a.m. UTC | #1
Hi,

Sorry for the late reply (in this thread).

On Sat, 05 Aug 2023 10:59:50 +0800,
Distopico wrote:
>
> * gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to a45d8b8 revision commit
>
> Fixes `telegram-desktop` calls that are not working with OpenSSL 3.
> Now, `webrtc-for-telegram-desktop` uses sources from the Guix `libsrtp`
> package instead of the submodule in the `unpack-additional-sources` phase.
>
> see: https://github.com/telegramdesktop/tdesktop/issues/26108
>
> ---
> * gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to a45d8b8 revision commit
>
> Fixes `telegram-desktop` calls that are not working with OpenSSL 3.
> Now, `webrtc-for-telegram-desktop` uses sources from the Guix `libsrtp`
> package instead of the submodule in the `unpack-additional-sources` phase.

Have you checked <https://github.com/desktop-app/tg_owt/pull/123>
(Unbundle libSRTP) yet?

`git grep include.*libsrtp' shows that `srtp_priv.h' is used, and it's
not present in libsrtp@2.4.2.  But since you have tested, I think it's
not an issue here.

For commit message, I think there's a 80-character limit and the long
sentences could be split into the [...] below as well.
--8<---------------cut here---------------start------------->8---
* gnu/packages/telegram.scm (...): ...
[snippet]: [...]
[#:phases]<unpack-additional-sources>: [...]
--8<---------------cut here---------------end--------------->8---

0-388.a45d8b8 can be used to describe the version if you prefer.

Patch LGTM, but if the aforementioned patch works, it's better to add
it.

Thanks
Hilton Chain Aug. 7, 2023, 12:26 p.m. UTC | #2
On Mon, 07 Aug 2023 17:38:57 +0800,
Hilton Chain wrote:
> `git grep include.*libsrtp' shows that `srtp_priv.h' is used, and it's
> not present in libsrtp@2.4.2.  But since you have tested, I think it's
> not an issue here.

Found it in libsrtp source!  So the reply's unrelated here.
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index aa01c2f692..0b32b49d14 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -265,8 +266,8 @@  (define tgcalls-for-telegram-desktop
       "193m2gkvipijqbfd6a8mhg9nd63wlnshzgspk3pip57vk21l709z"))))
 
 (define-public webrtc-for-telegram-desktop
-  (let ((commit "5098730b9eb6173f0b52068fe2555b7c1015123a")
-        (revision "328"))
+  (let ((commit "a45d8b8f0a99bd0e5118dda1dc4a8b7b3ad5dcfd")
+        (revision "388"))
     (hidden-package
      (package
        (name "webrtc-for-telegram-desktop")
@@ -282,14 +283,14 @@  (define-public webrtc-for-telegram-desktop
           (file-name
            (git-file-name name version))
           (sha256
-           (base32 "1lk54zlrff59rj5k9dylsgz4sdds4728psrk8m3v9qn5y8d6z8qy"))
+           (base32 "1qs3ikkd6l56brj40cv6wlhx5gj5avisj9mj8ypjfwcyw9hb2n5y"))
           (modules '((guix build utils)
                      (ice-9 ftw)
                      (srfi srfi-1)))
           (snippet
            #~(begin
                (let ((keep
-                      '("libsrtp" "rnnoise"
+                      '("rnnoise" "libsrtp_config"
                         ;; Not available in Guix.
                         "pffft")))
                  (with-directory-excursion "src/third_party"
@@ -311,9 +312,13 @@  (define-public webrtc-for-telegram-desktop
              (add-after 'unpack 'unpack-additional-sources
                (lambda _
                  (let* ((third-party (string-append (getcwd) "/src/third_party"))
-                        (libyuv-to (string-append third-party "/libyuv")))
+                        (libyuv-to (string-append third-party "/libyuv"))
+                        (libsrtp-to (string-append third-party "/libsrtp")))
                    (copy-recursively #$libyuv-for-telegram-desktop
-                                     libyuv-to)))))))
+                                     libyuv-to)
+                   (copy-recursively #$(package-source
+				        libsrtp)
+                                     libsrtp-to)))))))
        (native-inputs (list pkg-config python-wrapper yasm))
        (inputs
         (list abseil-cpp-cxxstd17