diff mbox series

[bug#64720,2/2] gnu: rust-analyzer: Fix build of version 2022-01-10.

Message ID 20230805024139.21189-2-distopico@riseup.net
State New
Headers show
Series Fix build of rust-analyzer v2022-01-10. | expand

Commit Message

Distopico Aug. 5, 2023, 2:40 a.m. UTC
* gnu/packages/rust-apps.scm (rust-analyzer): Update dependency rust-notify-5-pre.13.

This fixes the build of `rust-analyzer@2022-01-10`, which required a pinned
version of `rust-notify` (`rust-notify-5-pre.13`) to compile.
---
* gnu/packages/rust-apps.scm (rust-analyzer): Update dependency rust-notify-5-pre.13.

This fixes the build of `rust-analyzer@2022-01-10`, which required a pinned
version of `rust-notify` (`rust-notify-5-pre.13`) to compile.

 gnu/packages/rust-apps.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès Aug. 16, 2023, 9:09 p.m. UTC | #1
Hi,

Distopico <distopico@riseup.net> skribis:

> * gnu/packages/rust-apps.scm (rust-analyzer): Update dependency rust-notify-5-pre.13.
>
> This fixes the build of `rust-analyzer@2022-01-10`, which required a pinned
> version of `rust-notify` (`rust-notify-5-pre.13`) to compile.

When applied on top of 07dc3d024763f3768002e422e0d60aac0c1b94ac, I get
this on x86_64-linux:

--8<---------------cut here---------------start------------->8---
test abis::abi_1_58::rustc_server::tests::test_rustc_server_literals ... ok
test abis::abi_1_58::rustc_server::tests::test_rustc_server_to_string ... ok
test abis::abi_1_54::rustc_server::tests::test_rustc_server_from_str ... ok
test tests::test_derive_error ... FAILED
test tests::test_attr_macro ... FAILED
test tests::test_derive_empty ... FAILED
test tests::test_fn_like_macro2 ... FAILED
test tests::test_fn_like_macro ... FAILED
memory allocation of 140737312524592 bytes failed
error: test failed, to rerun pass `-p proc_macro_srv --lib`

Caused by:
  process didn't exit successfully: `/tmp/guix-build-rust-analyzer-2022-01-10.drv-0/source/target/release/deps/proc_macro_srv-ed08c83337741884 '--skip=tests::test_version_check' '--skip=tests::test_loading_rust_analyzer' '--skip=tests::sourcegen::sourcegen_assists_docs' '--skip=tests::sourcegen_ast::sourcegen_ast' '--skip=tidy::cargo_files_are_tidy' '--skip=tidy::check_licenses' '--skip=tidy::check_merge_commits' '--skip=tidy::check_code_formatting' '--skip=tidy::generate_grammar' '--skip=tidy::generate_assists_tests'` (signal: 6, SIGABRT: process abort signal)
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "cargo" arguments: ("test" "--release" "--" "--skip=tests::test_version_check" "--skip=tests::test_loading_rust_analyzer" "--skip=tests::sourcegen::sourcegen_assists_docs" "--skip=tests::sourcegen_ast::sourcegen_ast" "--skip=tidy::cargo_files_are_tidy" "--skip=tidy::check_licenses" "--skip=tidy::check_merge_commits" "--skip=tidy::check_code_formatting" "--skip=tidy::generate_grammar" "--skip=tidy::generate_assists_tests") exit-status: 101 term-signal: #f stop-signal: #f> 
phase `check' failed after 164.4 seconds
command "cargo" "test" "--release" "--" "--skip=tests::test_version_check" "--skip=tests::test_loading_rust_analyzer" "--skip=tests::sourcegen::sourcegen_assists_docs" "--skip=tests::sourcegen_ast::sourcegen_ast" "--skip=tidy::cargo_files_are_tidy" "--skip=tidy::check_licenses" "--skip=tidy::check_merge_commits" "--skip=tidy::check_code_formatting" "--skip=tidy::generate_grammar" "--skip=tidy::generate_assists_tests" failed with status 101
builder for `/gnu/store/qjpz8f8g5x5wx3y1lviz5kyy9hza4msp-rust-analyzer-2022-01-10.drv' failed with exit code 1
--8<---------------cut here---------------end--------------->8---

Could you take a look?

Thanks,
Ludo’.
Distopico Aug. 30, 2023, 8:34 p.m. UTC | #2
Hi  Ludo

On 2023-08-16, Ludovic Courtès <ludo@gnu.org> wrote:

> Hi,
>
> Distopico <distopico@riseup.net> skribis:
>
>> * gnu/packages/rust-apps.scm (rust-analyzer): Update dependency rust-notify-5-pre.13.
>>
>> This fixes the build of `rust-analyzer@2022-01-10`, which required a pinned
>> version of `rust-notify` (`rust-notify-5-pre.13`) to compile.
>
> When applied on top of 07dc3d024763f3768002e422e0d60aac0c1b94ac, I get
> this on x86_64-linux:
>
> --8<---------------cut here---------------start------------->8---
> test abis::abi_1_58::rustc_server::tests::test_rustc_server_literals ... ok
> test abis::abi_1_58::rustc_server::tests::test_rustc_server_to_string ... ok
> test abis::abi_1_54::rustc_server::tests::test_rustc_server_from_str ... ok
> test tests::test_derive_error ... FAILED
> test tests::test_attr_macro ... FAILED
> test tests::test_derive_empty ... FAILED
> test tests::test_fn_like_macro2 ... FAILED
> test tests::test_fn_like_macro ... FAILED
> memory allocation of 140737312524592 bytes failed
> error: test failed, to rerun pass `-p proc_macro_srv --lib`
>
> Caused by:
>   process didn't exit successfully: `/tmp/guix-build-rust-analyzer-2022-01-10.drv-0/source/target/release/deps/proc_macro_srv-ed08c83337741884 '--skip=tests::test_version_check' '--skip=tests::test_loading_rust_analyzer' '--skip=tests::sourcegen::sourcegen_assists_docs' '--skip=tests::sourcegen_ast::sourcegen_ast' '--skip=tidy::cargo_files_are_tidy' '--skip=tidy::check_licenses' '--skip=tidy::check_merge_commits' '--skip=tidy::check_code_formatting' '--skip=tidy::generate_grammar' '--skip=tidy::generate_assists_tests'` (signal: 6, SIGABRT: process abort signal)
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "cargo" arguments: ("test" "--release" "--" "--skip=tests::test_version_check" "--skip=tests::test_loading_rust_analyzer" "--skip=tests::sourcegen::sourcegen_assists_docs" "--skip=tests::sourcegen_ast::sourcegen_ast" "--skip=tidy::cargo_files_are_tidy" "--skip=tidy::check_licenses" "--skip=tidy::check_merge_commits" "--skip=tidy::check_code_formatting" "--skip=tidy::generate_grammar" "--skip=tidy::generate_assists_tests") exit-status: 101 term-signal: #f stop-signal: #f> 
> phase `check' failed after 164.4 seconds
> command "cargo" "test" "--release" "--" "--skip=tests::test_version_check" "--skip=tests::test_loading_rust_analyzer" "--skip=tests::sourcegen::sourcegen_assists_docs" "--skip=tests::sourcegen_ast::sourcegen_ast" "--skip=tidy::cargo_files_are_tidy" "--skip=tidy::check_licenses" "--skip=tidy::check_merge_commits" "--skip=tidy::check_code_formatting" "--skip=tidy::generate_grammar" "--skip=tidy::generate_assists_tests" failed with status 101
> builder for `/gnu/store/qjpz8f8g5x5wx3y1lviz5kyy9hza4msp-rust-analyzer-2022-01-10.drv' failed with exit code 1
> --8<---------------cut here---------------end--------------->8---
>
> Could you take a look?
>
> Thanks,
> Ludo’.

Fixed, thank you
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 8c29969712..0571af498c 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1775,7 +1775,7 @@  (define-public rust-analyzer
         ("rust-memmap2" ,rust-memmap2-0.5)
         ("rust-mimalloc" ,rust-mimalloc-0.1)
         ("rust-miow" ,rust-miow-0.4)
-        ("rust-notify" ,rust-notify-5)
+        ("rust-notify" ,rust-notify-5-pre.13)
         ("rust-object" ,rust-object-0.28)
         ("rust-once-cell" ,rust-once-cell-1)
         ("rust-parking-lot" ,rust-parking-lot-0.11)